summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 08:19:25 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 08:19:25 +0000
commita654234c2833e507e4c5377103d91de6a6fd8964 (patch)
tree318041cab1b2efa21a6e6e64207193bb304e7649
parent2024-07-15 08:04:40 UTC (diff)
parentdev-python/psycopg: mark as strict-aliasing unsafe (diff)
downloadgentoo-a654234c2833e507e4c5377103d91de6a6fd8964.tar.gz
gentoo-a654234c2833e507e4c5377103d91de6a6fd8964.tar.bz2
gentoo-a654234c2833e507e4c5377103d91de6a6fd8964.zip
Merge updates from master
-rw-r--r--dev-python/psycopg/psycopg-3.1.19.ebuild10
-rw-r--r--dev-python/psycopg/psycopg-3.2.0.ebuild10
-rw-r--r--dev-python/psycopg/psycopg-3.2.1.ebuild10
-rw-r--r--media-tv/tvheadend/tvheadend-4.3_p20240618.ebuild1
-rw-r--r--media-tv/tvheadend/tvheadend-9999.ebuild1
-rw-r--r--sci-libs/fftw/fftw-3.3.10.ebuild18
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild18
7 files changed, 57 insertions, 11 deletions
diff --git a/dev-python/psycopg/psycopg-3.1.19.ebuild b/dev-python/psycopg/psycopg-3.1.19.ebuild
index d1c0ba870de9..15b4a76bbc7e 100644
--- a/dev-python/psycopg/psycopg-3.1.19.ebuild
+++ b/dev-python/psycopg/psycopg-3.1.19.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="PostgreSQL database adapter for Python"
HOMEPAGE="
@@ -52,6 +52,14 @@ BDEPEND="
distutils_enable_tests pytest
python_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/935401
+ # https://github.com/psycopg/psycopg/issues/867
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Python code + ctypes backend
cd psycopg || die
distutils-r1_python_compile
diff --git a/dev-python/psycopg/psycopg-3.2.0.ebuild b/dev-python/psycopg/psycopg-3.2.0.ebuild
index 1bcf3b3ac2e0..d62b5590fa54 100644
--- a/dev-python/psycopg/psycopg-3.2.0.ebuild
+++ b/dev-python/psycopg/psycopg-3.2.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="PostgreSQL database adapter for Python"
HOMEPAGE="
@@ -54,6 +54,14 @@ BDEPEND="
distutils_enable_tests pytest
python_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/935401
+ # https://github.com/psycopg/psycopg/issues/867
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Python code + ctypes backend
cd psycopg || die
distutils-r1_python_compile
diff --git a/dev-python/psycopg/psycopg-3.2.1.ebuild b/dev-python/psycopg/psycopg-3.2.1.ebuild
index 1bcf3b3ac2e0..d62b5590fa54 100644
--- a/dev-python/psycopg/psycopg-3.2.1.ebuild
+++ b/dev-python/psycopg/psycopg-3.2.1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="PostgreSQL database adapter for Python"
HOMEPAGE="
@@ -54,6 +54,14 @@ BDEPEND="
distutils_enable_tests pytest
python_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/935401
+ # https://github.com/psycopg/psycopg/issues/867
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Python code + ctypes backend
cd psycopg || die
distutils-r1_python_compile
diff --git a/media-tv/tvheadend/tvheadend-4.3_p20240618.ebuild b/media-tv/tvheadend/tvheadend-4.3_p20240618.ebuild
index 733fd0370d43..ad4beb9c15f2 100644
--- a/media-tv/tvheadend/tvheadend-4.3_p20240618.ebuild
+++ b/media-tv/tvheadend/tvheadend-4.3_p20240618.ebuild
@@ -92,6 +92,7 @@ pkg_setup() {
src_configure() {
# -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/932794
# https://github.com/tvheadend/tvheadend/issues/1732
filter-lto
diff --git a/media-tv/tvheadend/tvheadend-9999.ebuild b/media-tv/tvheadend/tvheadend-9999.ebuild
index 91152498ae00..d351184bd715 100644
--- a/media-tv/tvheadend/tvheadend-9999.ebuild
+++ b/media-tv/tvheadend/tvheadend-9999.ebuild
@@ -89,6 +89,7 @@ pkg_setup() {
src_configure() {
# -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/932794
# https://github.com/tvheadend/tvheadend/issues/1732
filter-lto
diff --git a/sci-libs/fftw/fftw-3.3.10.ebuild b/sci-libs/fftw/fftw-3.3.10.ebuild
index 213b53606d55..ea7a5189348f 100644
--- a/sci-libs/fftw/fftw-3.3.10.ebuild
+++ b/sci-libs/fftw/fftw-3.3.10.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2 multibuild multilib-minimal toolchain-funcs
+inherit fortran-2 libtool multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
HOMEPAGE="https://www.fftw.org/"
@@ -33,6 +33,12 @@ BDEPEND="test? ( dev-lang/perl )"
HTML_DOCS=( doc/html/. )
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # check fails with any version of gcc. On <14:
+ # <artificial>:(.text.startup+0x19): undefined reference to `_rtc'
+ _rtc
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
@@ -50,8 +56,12 @@ pkg_setup() {
src_prepare() {
default
- # fix info file for category directory
- [[ ${PV} == *9999 ]] && eautoreconf
+ if [[ ${PV} == *9999 ]]; then
+ # fix info file for category directory
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
multilib_src_configure() {
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index f3fa7dd693b0..176526968102 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
FORTRAN_NEEDED=fortran
-inherit fortran-2 multibuild multilib-minimal toolchain-funcs
+inherit fortran-2 libtool multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
HOMEPAGE="https://www.fftw.org/"
@@ -33,6 +33,12 @@ BDEPEND="test? ( dev-lang/perl )"
HTML_DOCS=( doc/html/. )
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # check fails with any version of gcc. On <14:
+ # <artificial>:(.text.startup+0x19): undefined reference to `_rtc'
+ _rtc
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
@@ -50,8 +56,12 @@ pkg_setup() {
src_prepare() {
default
- # fix info file for category directory
- [[ ${PV} == *9999 ]] && eautoreconf
+ if [[ ${PV} == *9999 ]]; then
+ # fix info file for category directory
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
multilib_src_configure() {