summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-08-19 11:49:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-08-19 11:49:52 +0000
commit920a6e507572fa163f4815f119ba7fdb7bc7d74d (patch)
tree84cca58a1001b32cfc7b04a6b4396267fdd8a35e
parent2024-08-19 11:34:05 UTC (diff)
parentapp-emacs/zenburn-theme: Add theme to custom-safe-themes (diff)
downloadgentoo-920a6e507572fa163f4815f119ba7fdb7bc7d74d.tar.gz
gentoo-920a6e507572fa163f4815f119ba7fdb7bc7d74d.tar.bz2
gentoo-920a6e507572fa163f4815f119ba7fdb7bc7d74d.zip
Merge updates from master
-rw-r--r--app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el1
-rw-r--r--app-emacs/zenburn-theme/zenburn-theme-2.7.0-r1.ebuild (renamed from app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild)8
2 files changed, 7 insertions, 2 deletions
diff --git a/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el b/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el
index 002aaf546293..0f3b6bf3b24a 100644
--- a/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el
+++ b/app-emacs/zenburn-theme/files/50zenburn-theme-gentoo.el
@@ -1 +1,2 @@
(add-to-list 'custom-theme-load-path "@SITEETC@")
+(add-to-list 'custom-safe-themes "@SHA256@")
diff --git a/app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild b/app-emacs/zenburn-theme/zenburn-theme-2.7.0-r1.ebuild
index 4b8491dc0111..c84c101ecdcc 100644
--- a/app-emacs/zenburn-theme/zenburn-theme-2.7.0.ebuild
+++ b/app-emacs/zenburn-theme/zenburn-theme-2.7.0-r1.ebuild
@@ -20,7 +20,11 @@ SITEFILE="50${PN}-gentoo.el"
src_install() {
insinto "${SITEETC}/${PN}"
doins zenburn-theme.el
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ local sha256=$(sha256sum zenburn-theme.el) || die
+ sed "s:@SHA256@:${sha256%% *}:" "${FILESDIR}/${SITEFILE}" \
+ > "${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}"
dodoc CHANGELOG.md CONTRIBUTING.md README.md
dodoc -r screenshots
@@ -28,6 +32,6 @@ src_install() {
local DOC_CONTENTS="To enable zenburn by default, initialise it
in your ~/.emacs:
- \n\t(load-theme 'zenburn 'no-confirm)"
+ \n\t(load-theme 'zenburn)"
readme.gentoo_create_doc
}