summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-04-15 10:36:37 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-04-15 10:36:37 +0300
commit395d757c4d0a5cd586e49f32aaf5c2802a3ad297 (patch)
treeadf659fffb24d077802b906597b0a1e45dd24e00
parentdev-python/traitsui: remove last rited package (diff)
downloadgentoo-395d757c4d0a5cd586e49f32aaf5c2802a3ad297.tar.gz
gentoo-395d757c4d0a5cd586e49f32aaf5c2802a3ad297.tar.bz2
gentoo-395d757c4d0a5cd586e49f32aaf5c2802a3ad297.zip
dev-python/traits: remove last rited package
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--dev-python/traits/Manifest2
-rw-r--r--dev-python/traits/metadata.xml26
-rw-r--r--dev-python/traits/traits-4.5.0.ebuild38
-rw-r--r--dev-python/traits/traits-4.6.0.ebuild40
4 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/traits/Manifest b/dev-python/traits/Manifest
deleted file mode 100644
index 2c5713d13715..000000000000
--- a/dev-python/traits/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST traits-4.5.0.tar.gz 4853612 BLAKE2B 6c3d83718751de1e0553487a45d073c285ada96686558133fe61472c29c3d4661e1c0bce68340bada9667f3f9e0c8ed11050a714bc0c55424dbd4ebd17e3ad8e SHA512 d506b4395395898eb824896d299bfcde609e100025cf9a55cd7d7c47615545efd3b007e46549e564fbfb2d5882b36ae676843f211f168b2557c504849c5ef582
-DIST traits-4.6.0.tar.gz 434937 BLAKE2B 91d457b411f78b74a077f3bfaa8e3f627d0ddb959784ba0ce9e07e3fc8b76cddcaee1fd7293d8336c4fc0630d49527fd29e1a9ccba6b724846069f6282c643e8 SHA512 0fce336696e4cbb1d4ba63a07ad42867cb179a9efa6c348623036bd6d2eb791302539ae89994b11acd5a9f1be42a0febeb517db1716342b78aa71ca1277fde99
diff --git a/dev-python/traits/metadata.xml b/dev-python/traits/metadata.xml
deleted file mode 100644
index 0e2713e3142b..000000000000
--- a/dev-python/traits/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>horea.christ@gmail.com</email>
- <name>Horea Christian</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription lang="en">
- The traits package from the Enthought Tool Suite provides a
- metaclass with special attributes that are called traits. A trait
- is a type definition that can be used for normal Python object
- attributes, giving the attributes some additional characteristics:
- * Initialization: A trait attribute can have a default value
- * Validation: A trait attribute is manifestly typed.
- * Delegation: The value of a trait attribute can be contained in another object
- * Notification: Setting the value of a trait attribute can fired callbacks
- * Visualization: With the TraitsUI package, GUIs can be generated automatically from traited objects.
- </longdescription>
- <upstream>
- <remote-id type="pypi">traits</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/traits/traits-4.5.0.ebuild b/dev-python/traits/traits-4.5.0.ebuild
deleted file mode 100644
index aa0e34305e32..000000000000
--- a/dev-python/traits/traits-4.5.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://docs.enthought.com/traits/
- https://github.com/enthought/traits
- https://pypi.org/project/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}
diff --git a/dev-python/traits/traits-4.6.0.ebuild b/dev-python/traits/traits-4.6.0.ebuild
deleted file mode 100644
index d3d48e925b4f..000000000000
--- a/dev-python/traits/traits-4.6.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://docs.enthought.com/traits/
- https://github.com/enthought/traits
- https://pypi.org/project/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}