aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucian.poston@gmail.com>2018-02-02 12:57:37 -0800
committerNP-Hardass <NP-Hardass@gentoo.org>2018-03-01 17:25:20 -0500
commit3c755937e6491307de07251ad76c2d78a1534dd4 (patch)
treec5ab056510ec764f9eb12076f464692a4146a8a0 /app-emulation/wine-d3d9
parentapp-emulation/wine-vanilla: Bump to 3.1 (diff)
downloadwine-3c755937e6491307de07251ad76c2d78a1534dd4.tar.gz
wine-3c755937e6491307de07251ad76c2d78a1534dd4.tar.bz2
wine-3c755937e6491307de07251ad76c2d78a1534dd4.zip
app-emulation/wine-d3d9: Add gssapi USE flag to 9999
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-emulation/wine-d3d9')
-rw-r--r--app-emulation/wine-d3d9/metadata.xml1
-rw-r--r--app-emulation/wine-d3d9/wine-d3d9-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/wine-d3d9/metadata.xml b/app-emulation/wine-d3d9/metadata.xml
index 375e226..06a76c9 100644
--- a/app-emulation/wine-d3d9/metadata.xml
+++ b/app-emulation/wine-d3d9/metadata.xml
@@ -27,6 +27,7 @@ This variant of the Wine packaging includes the Gallium Nine patchset.
This patch may break some applications.</flag>
<flag name="dos">Pull in <pkg>games-emulation/dosbox</pkg> to run DOS applications</flag>
<flag name="gecko">Add support for the Gecko engine when using iexplore</flag>
+ <flag name="gssapi">Use GSSAPI (Kerberos SSP support)</flag>
<flag name="gstreamer">Use <pkg>media-libs/gstreamer</pkg> to provide DirectShow functionality;</flag>
<flag name="mono">Add support for .NET using Wine's Mono add-on</flag>
<flag name="netapi">Use libnetapi from <pkg>net-fs/samba</pkg> to support Windows networks in netapi32.dll</flag>
diff --git a/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild b/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
index ddbc7bc..b5caa38 100644
--- a/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
+++ b/app-emulation/wine-d3d9/wine-d3d9-9999.ebuild
@@ -44,7 +44,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap +png prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype udev +udisks v4l +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap +png prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype udev +udisks v4l +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -76,6 +76,7 @@ COMMON_DEPEND="
fontconfig? ( media-libs/fontconfig:=[${MULTILIB_USEDEP}] )
gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
gsm? ( media-sound/gsm:=[${MULTILIB_USEDEP}] )
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
gstreamer? (
media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
media-plugins/gst-plugins-meta:1.0[${MULTILIB_USEDEP}]
@@ -429,6 +430,7 @@ multilib_src_configure() {
$(use_enable gecko mshtml)
$(use_with gphoto2 gphoto)
$(use_with gsm)
+ $(use_with gssapi)
$(use_with gstreamer)
--without-hal
$(use_with jpeg)