aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2020-09-29 18:32:11 -0400
committerNick Sarnie <sarnex@gentoo.org>2020-09-29 18:32:11 -0400
commit468cd930fd7bc7f2048d559ff3afee75288561a5 (patch)
tree9665bdce261c3f5dd288215556b653c580276107 /app-emulation/vkd3d
parentapp-emulation/wine-staging: Bump to 5.18 (diff)
downloadwine-468cd930fd7bc7f2048d559ff3afee75288561a5.tar.gz
wine-468cd930fd7bc7f2048d559ff3afee75288561a5.tar.bz2
wine-468cd930fd7bc7f2048d559ff3afee75288561a5.zip
app-emulation/vkd3d: Fix build
Closes: https://bugs.gentoo.org/745450 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/vkd3d-1.2.ebuild1
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild9
2 files changed, 5 insertions, 5 deletions
diff --git a/app-emulation/vkd3d/vkd3d-1.2.ebuild b/app-emulation/vkd3d/vkd3d-1.2.ebuild
index f866aca..90e8035 100644
--- a/app-emulation/vkd3d/vkd3d-1.2.ebuild
+++ b/app-emulation/vkd3d/vkd3d-1.2.ebuild
@@ -33,6 +33,7 @@ SLOT="0"
multilib_src_configure() {
local myconf=(
$(use_with spirv-tools)
+ --disable-doxygen-pdf
)
ECONF_SOURCE=${S} econf "${myconf[@]}"
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
index 56cb485..90e8035 100644
--- a/app-emulation/vkd3d/vkd3d-9999.ebuild
+++ b/app-emulation/vkd3d/vkd3d-9999.ebuild
@@ -1,17 +1,15 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit multilib-minimal
-AUTOTOOLS_AUTORECONF="1"
-
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
inherit git-r3
else
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
fi
@@ -24,7 +22,7 @@ RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
DEPEND="${RDEPEND}
dev-util/spirv-headers
- >=dev-util/vulkan-headers-1.1.114"
+ dev-util/vulkan-headers"
DESCRIPTION="D3D12 to Vulkan translation library"
HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
@@ -35,6 +33,7 @@ SLOT="0"
multilib_src_configure() {
local myconf=(
$(use_with spirv-tools)
+ --disable-doxygen-pdf
)
ECONF_SOURCE=${S} econf "${myconf[@]}"