aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcnd <cynede@gentoo.org>2019-09-15 19:19:59 +0400
committerGitHub <noreply@github.com>2019-09-15 19:19:59 +0400
commit990c7dc9417c9ba7f58bc5c4f0055ea789466a48 (patch)
treec1356010b03274b40a7a0b7fbc1fe16572fdb447 /dev-lang
parentMerge pull request #439 from stefson/rust-9999 (diff)
parentdev-lang/rust-bin-9999: add arm64 support and keyword it (diff)
downloadrust-990c7dc9417c9ba7f58bc5c4f0055ea789466a48.tar.gz
rust-990c7dc9417c9ba7f58bc5c4f0055ea789466a48.tar.bz2
rust-990c7dc9417c9ba7f58bc5c4f0055ea789466a48.zip
Merge pull request #437 from stefson/rust-bin-fix
dev-lang/rust-bin-9999: add armv7 and aarch64 support
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/rust-bin-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/rust-bin/rust-bin-9999.ebuild b/dev-lang/rust-bin/rust-bin-9999.ebuild
index b5a82d1..bbb15b4 100644
--- a/dev-lang/rust-bin/rust-bin-9999.ebuild
+++ b/dev-lang/rust-bin/rust-bin-9999.ebuild
@@ -17,7 +17,7 @@ ALL_RUSTLIB_TARGETS=( "${ALL_RUSTLIB_TARGETS[@]/#/rustlib_targets_}" )
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="nightly"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="clippy cpu_flags_x86_sse2 doc libressl rls rustfmt ${ALL_RUSTLIB_TARGETS[*]}"
CDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
@@ -48,6 +48,8 @@ src_unpack() {
local postfix
use amd64 && postfix=x86_64-unknown-linux-gnu
use x86 && postfix=i686-unknown-linux-gnu
+ use arm && postfix=armv7-unknown-linux-gnueabihf
+ use arm64 && postfix=aarch64-unknown-linux-gnu
wget "${MY_SRC_URI}-${postfix}.tar.xz" || die
unpack ./"rust-nightly-${postfix}.tar.xz"