aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOGINO Masanori <masanori.ogino@gmail.com>2013-12-24 20:31:41 +0900
committerOGINO Masanori <masanori.ogino@gmail.com>2013-12-24 20:31:41 +0900
commitd7e158b94566ecf30edacba48b8bd34ffc80cb6f (patch)
tree402dfbb381e97831e8e6263d5deffe1bbe1b0106 /app-vim
parentdon't be so selfish (diff)
downloadrust-d7e158b94566ecf30edacba48b8bd34ffc80cb6f.tar.gz
rust-d7e158b94566ecf30edacba48b8bd34ffc80cb6f.tar.bz2
rust-d7e158b94566ecf30edacba48b8bd34ffc80cb6f.zip
Add app-vim/rust-mode.
I'm unsure whether the name rust-mode is right, but it installs not only syntax/ script, so i think rust-syntax is not so good. I borrowed the name from app-vim/python-mode. I think I shouldn't fill the maintainer field with the your address even if it seems natural, so I don't write metadata.xml. If you are willing to maintain this, could you write it? Signed-off-by: OGINO Masanori <masanori.ogino@gmail.com>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/rust-mode/Manifest1
-rw-r--r--app-vim/rust-mode/rust-mode-0.8.ebuild32
-rw-r--r--app-vim/rust-mode/rust-mode-9999.ebuild32
3 files changed, 65 insertions, 0 deletions
diff --git a/app-vim/rust-mode/Manifest b/app-vim/rust-mode/Manifest
new file mode 100644
index 0000000..33476d6
--- /dev/null
+++ b/app-vim/rust-mode/Manifest
@@ -0,0 +1 @@
+DIST rust-0.8.tar.gz 16720822 SHA256 42f791ab1537357fe0f63d67ffe6bcb64ecf16b2bd3f1484ab589823f5914182 SHA512 494817e045af87055ca22a6b15799f14ab4e5a4d1e7be883c211bfbbc2b9b1c498711d91c40c130dd8b8307f226d4ed6100b51064aab8a9f3939f19bd829b0e4 WHIRLPOOL 907838591486cf6336b697bab338ca3aa970f2c0daa352c78dba53ccaa5bb77b3f1e2f110b345bab67e4476846a30b71c612ee0726176b23e49bc3fd4cba17e3
diff --git a/app-vim/rust-mode/rust-mode-0.8.ebuild b/app-vim/rust-mode/rust-mode-0.8.ebuild
new file mode 100644
index 0000000..f549c3a
--- /dev/null
+++ b/app-vim/rust-mode/rust-mode-0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting, indentation, quickfix and other useful things for editing Rust code"
+HOMEPAGE="http://www.rust-lang.org/"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+if [[ ${PV} != 9999 ]]; then
+ MY_P="rust-${PV}"
+ SRC_URI="http://static.rust-lang.org/dist/${MY_P}.tar.gz"
+
+ S="${WORKDIR}/${MY_P}/src/etc/vim"
+else
+ EGIT_SOURCEDIR="${S}"
+ S="${S}/src/etc/vim"
+
+ inherit git-2
+
+ EGIT_REPO_URI="git://github.com/mozilla/rust.git"
+fi
+
+src_configure() {
+ echo "just for suppressing econf"
+}
diff --git a/app-vim/rust-mode/rust-mode-9999.ebuild b/app-vim/rust-mode/rust-mode-9999.ebuild
new file mode 100644
index 0000000..799178d
--- /dev/null
+++ b/app-vim/rust-mode/rust-mode-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting, indentation, quickfix and other useful things for editing Rust code"
+HOMEPAGE="http://www.rust-lang.org/"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS=""
+
+if [[ ${PV} != 9999 ]]; then
+ MY_P="rust-${PV}"
+ SRC_URI="http://static.rust-lang.org/dist/${MY_P}.tar.gz"
+
+ S="${WORKDIR}/${MY_P}/src/etc/vim"
+else
+ EGIT_SOURCEDIR="${S}"
+ S="${S}/src/etc/vim"
+
+ inherit git-2
+
+ EGIT_REPO_URI="git://github.com/mozilla/rust.git"
+fi
+
+src_configure() {
+ echo "just for suppressing econf"
+}