summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-08-22 14:42:29 +0200
committerFabian Groffen <grobian@gentoo.org>2021-08-22 14:42:29 +0200
commitd6138cf58cf7cce3b98c649099ea2f920513820f (patch)
tree9d2faf9dfb49fdb243f2c8207b258da2d909da62 /dev-lang
parentscripts/bootstrap-prefix: bump snapshot for newer Portage (diff)
downloadprefix-d6138cf58cf7cce3b98c649099ea2f920513820f.tar.gz
prefix-d6138cf58cf7cce3b98c649099ea2f920513820f.tar.bz2
prefix-d6138cf58cf7cce3b98c649099ea2f920513820f.zip
dev-lang/python-3.9.6_p1: fix build on Darwin 19
Package-Manager: Portage-3.0.21-prefix, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.9.6_p1.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.9.6_p1.ebuild b/dev-lang/python/python-3.9.6_p1.ebuild
index 951f0c2540..844cd297c2 100644
--- a/dev-lang/python/python-3.9.6_p1.ebuild
+++ b/dev-lang/python/python-3.9.6_p1.ebuild
@@ -124,6 +124,16 @@ src_prepare() {
configure.ac configure || die
fi
+ if [[ ${CHOST} == *-darwin19 ]] ; then
+ # HAVE_DYLD_SHARED_CACHE_CONTAINS_PATH is set because
+ # _dyld_shared_cache_contains_path could be found, yet it cannot
+ # be resolved when dlopen()ing, so simply pretend it doesn't
+ # exist here
+ sed -i \
+ -e 's/_dyld_shared_cache_contains_path/disabled&/' \
+ configure.ac configure || die
+ fi
+
eautoreconf
}