summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-07-12 12:19:54 +0200
committerFabian Groffen <grobian@gentoo.org>2024-07-12 12:19:54 +0200
commit6759c9f81dd5cdde383efc766cf895c84a92caef (patch)
treeaa3c930d0fa4445cee15f2df2beeebe8bc581932
parentpts/rsync-generation/update-rsync-master: fix PYTHONPATH (diff)
downloadprefix-6759c9f81dd5cdde383efc766cf895c84a92caef.tar.gz
prefix-6759c9f81dd5cdde383efc766cf895c84a92caef.tar.bz2
prefix-6759c9f81dd5cdde383efc766cf895c84a92caef.zip
sys-libs/newlib: remove in favour of gx86 version
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--sys-libs/newlib/files/cygwin-2.7.0-parallel-build.patch31
-rw-r--r--sys-libs/newlib/metadata.xml11
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild95
3 files changed, 0 insertions, 137 deletions
diff --git a/sys-libs/newlib/files/cygwin-2.7.0-parallel-build.patch b/sys-libs/newlib/files/cygwin-2.7.0-parallel-build.patch
deleted file mode 100644
index 7dce4e28e9..0000000000
--- a/sys-libs/newlib/files/cygwin-2.7.0-parallel-build.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 2f3758437166c57fd53ad8517d874d95f27710bc Mon Sep 17 00:00:00 2001
-From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
-Date: Thu, 16 Feb 2017 14:32:07 +0100
-Subject: [PATCH] fix parallel build for version.cc and winver.o
-
-Creating both version.cc and winver.o at once really should run once only.
----
- winsup/cygwin/Makefile.in | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/winsup/cygwin/Makefile.in b/winsup/cygwin/Makefile.in
-index bffb24a..c8652b0 100644
---- a/winsup/cygwin/Makefile.in
-+++ b/winsup/cygwin/Makefile.in
-@@ -747,10 +747,12 @@ libacl.a: ${LIB_NAME} sec_posixacl.o
- ${EXTRALIBS}: lib%.a: %.o
- $(AR) cru $@ $?
-
--version.cc winver.o: mkvers.sh include/cygwin/version.h winver.rc $(DLL_OFILES)
-+winver.o: mkvers.sh include/cygwin/version.h winver.rc $(DLL_OFILES)
- @echo "Making version.cc and winver.o";\
- /bin/sh ${word 1,$^} ${word 2,$^} ${word 3,$^} $(WINDRES) ${CFLAGS} $(addprefix -I,${CCWRAP_SYSTEM_HEADERS} ${CCWRAP_DIRAFTER_HEADERS})
-
-+version.cc: winver.o
-+
- Makefile: ${srcdir}/Makefile.in
- /bin/sh ./config.status
-
---
-2.10.2
-
diff --git a/sys-libs/newlib/metadata.xml b/sys-libs/newlib/metadata.xml
deleted file mode 100644
index 3002cfebe8..0000000000
--- a/sys-libs/newlib/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
-<email>lu_zero@gentoo.org</email>
-</maintainer>
-<maintainer type="project">
-<email>toolchain@gentoo.org</email>
-<name>Gentoo Toolchain Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
deleted file mode 100644
index 6c5e40f34d..0000000000
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- if [[ ${PV} != *.201[5-9]???? ]] ; then
- KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86"
- fi
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf|*-cygwin*) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-}
-
-src_prepare() {
- default
- if [[ ${CHOST} == *-cygwin* ]] ; then
- local pvgr="${PV}-gentoo-${PR}"
- pvgr=${pvgr%-r0}
- einfo "Branding Gentoo/Cygwin ${pvgr} ..."
- sed -i -e "/Cygwin dll release/a\
- __small_sprintf (name->release, \"%s\", \"${pvgr}\") ||
- " winsup/cygwin/uname.cc || die
- eend $?
- fi
-}
-
-src_configure() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET:-${CHOST}} strip-unsupported-flags
-
- local myconf=(
- # Disable legacy syscall stub code in newlib. These have been
- # moved to libgloss for a long time now, so the code in newlib
- # itself just gets in the way.
- --disable-newlib-supplied-syscalls
- )
- [[ ${CTARGET} == "spu" ]] \
- && myconf+=( --disable-newlib-multithread ) \
- || myconf+=( $(use_enable threads newlib-multithread) )
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- "${myconf[@]}"
-}
-
-src_compile() {
- emake -C "${NEWLIBBUILD}"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
-# env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}