aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-04-12 18:57:21 -0700
committerorbea <orbea@riseup.net>2023-04-12 18:58:09 -0700
commit168e1225785b12316d53a5e0322dc77b1ece5d3b (patch)
tree8e2345030a030cb163ff77dcfeb0a9158e98b54b /net-analyzer
parentmail-filter/imapfilter: Merge ::gentoo changes (diff)
downloadlibressl-168e1225785b12316d53a5e0322dc77b1ece5d3b.tar.gz
libressl-168e1225785b12316d53a5e0322dc77b1ece5d3b.tar.bz2
libressl-168e1225785b12316d53a5e0322dc77b1ece5d3b.zip
net-analyzer/ettercap: add 0.8.3.1-r2
Includes Gentoo PR: https://github.com/gentoo/gentoo/pull/30577 Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.1-r2.ebuild (renamed from net-analyzer/ettercap/ettercap-0.8.3.1.ebuild)44
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch32
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch39
3 files changed, 99 insertions, 16 deletions
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.1-r2.ebuild
index 069c391..72f2ab5 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.1-r2.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A suite for man in the middle attacks"
+DESCRIPTION="Suite for man in the middle attacks"
HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
else
@@ -22,15 +22,16 @@ fi
IUSE="doc geoip gtk ipv6 ncurses +plugins test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libbsd
+RDEPEND="
+ dev-libs/libbsd
dev-libs/libpcre
- dev-libs/openssl:0=
+ dev-libs/openssl:=
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
geoip? ( dev-libs/geoip )
gtk? (
- >=dev-libs/atk-1.2.4
+ >=app-accessibility/at-spi2-core-2.46.0
>=dev-libs/glib-2.2.2:2
media-libs/freetype
x11-libs/cairo
@@ -39,15 +40,25 @@ RDEPEND="dev-libs/libbsd
>=x11-libs/pango-1.2.3
)
ncurses? ( >=sys-libs/ncurses-5.3:= )
- plugins? ( >=net-misc/curl-7.26.0 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl
- sys-apps/groff )
- test? ( dev-libs/check )
+ plugins? ( >=net-misc/curl-7.26.0 )
+"
+DEPEND="
+ app-alternatives/yacc
sys-devel/flex
- virtual/yacc"
+"
+BDEPEND="
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+ test? ( dev-libs/check )
+"
-PATCHES=( "${FILESDIR}"/${P}-libressl.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-curl-8.patch
+ "${FILESDIR}"/${P}-musl.patch #897820
+ "${FILESDIR}"/${P}-libressl.patch
+)
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -68,8 +79,9 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${EPREFIX}"/etc
)
+ # right now we only support gtk2, but ettercap also supports gtk3
+ # do we care? do we want to support both?
! use gtk && mycmakeargs+=(-DINSTALL_DESKTOP=OFF)
- #right now we only support gtk2, but ettercap also supports gtk3
- #do we care? do we want to support both?
+
cmake_src_configure
}
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch
new file mode 100644
index 0000000..e1c2259
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/902987
+https://github.com/Ettercap/ettercap/commit/40534662043b7d831d1f6c70448afa9d374a9b63
+
+From 40534662043b7d831d1f6c70448afa9d374a9b63 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 23 Mar 2023 10:23:14 -0700
+Subject: [PATCH] sslstrip: Enhance the libcurl version check to consider
+ version 8+
+
+Lately curl has released version 8 and hence LIBCURL_VERSION_MAJOR is
+reset to 0, current check assumes major version to be 7 at max and hence
+on systems with libcurl 8+ this check breaks and build fails
+
+Fixes
+
+TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/ettercap/0.8.3.1-r0/git/plug-ins/sslstrip/sslstrip.c:57:2: error: libcurl 7.26.0 or up is needed
+ ^
+1 error generated.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/plug-ins/sslstrip/sslstrip.c
++++ b/plug-ins/sslstrip/sslstrip.c
+@@ -51,7 +51,7 @@
+
+ #include <curl/curl.h>
+
+-#if (LIBCURL_VERSION_MAJOR < 7) || (LIBCURL_VERSION_MINOR < 26)
++#if (LIBCURL_VERSION_MAJOR < 7) || (LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR < 26)
+ #error libcurl 7.26.0 or up is needed
+ #endif
+
+
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch
new file mode 100644
index 0000000..516823e
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch
@@ -0,0 +1,39 @@
+Upsream-PR: https://github.com/Ettercap/ettercap/pull/1220
+Uptream-Commit: https://github.com/Ettercap/ettercap/commit/f03a1174ffccf9343423498fa3c65bd9090d4ce0
+Bug: https://bugs.gentoo.org/897820
+
+From 3ef51159d4e2cea97accb87af08943333fbefb04 Mon Sep 17 00:00:00 2001
+From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Date: Fri, 3 Mar 2023 21:27:14 +0100
+Subject: [PATCH] Define _GNU_SOURCE to make sure memmem is found when musl
+ library is used. This fixes issue: #1219
+
+Thanks Sam James for the suggestion!
+---
+ include/ec.h | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/include/ec.h b/include/ec.h
+index fbf048111..561062c2f 100644
+--- a/include/ec.h
++++ b/include/ec.h
+@@ -21,6 +21,9 @@
+ #if !defined (__USE_GNU) /* for memmem(), strsignal(), etc etc... */
+ #define __USE_GNU
+ #endif
++#if !defined (_GNU_SOURCE) /* for memmem(), strsignal(), etc etc... on musl */
++ #define _GNU_SOURCE
++#endif
+ #ifdef OS_SOLARIS
+ #define _REENTRANT /* for strtok_r() */
+ #endif
+@@ -28,6 +31,9 @@
+ #if defined (__USE_GNU)
+ #undef __USE_GNU
+ #endif
++#if defined (_GNU_SOURCE)
++ #undef _GNU_SOURCE
++#endif
+ #include <strings.h>
+ #include <unistd.h>
+ #include <time.h>