aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-06-11 12:21:01 -0700
committerorbea <orbea@riseup.net>2024-06-11 12:21:01 -0700
commit7796878dbdb74004e30c2b0bbd3afab668dd23cc (patch)
tree5fdad97ed4188677354523b52fbf0207b1ca39ab
parentdev-qt/qtbase: sync ::gentoo (diff)
downloadlibressl-7796878dbdb74004e30c2b0bbd3afab668dd23cc.tar.gz
libressl-7796878dbdb74004e30c2b0bbd3afab668dd23cc.tar.bz2
libressl-7796878dbdb74004e30c2b0bbd3afab668dd23cc.zip
dev-qt/qtbase: drop 6.7.0-r2
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--dev-qt/qtbase/Manifest1
-rw-r--r--dev-qt/qtbase/files/qtbase-6.7.0-CVE-2024-33861.patch23
-rw-r--r--dev-qt/qtbase/files/qtbase-6.7.0-qspan-ifdef.patch29
-rw-r--r--dev-qt/qtbase/qtbase-6.7.0-r2.ebuild384
4 files changed, 0 insertions, 437 deletions
diff --git a/dev-qt/qtbase/Manifest b/dev-qt/qtbase/Manifest
index 5852d21..0b37c03 100644
--- a/dev-qt/qtbase/Manifest
+++ b/dev-qt/qtbase/Manifest
@@ -1,2 +1 @@
-DIST qtbase-everywhere-src-6.7.0.tar.xz 49314276 BLAKE2B f4ec35fd3c15d56a28e1608dec927eaf34d84c2250405d921adadc16d90ec148f4983024dcf9be1832de91381d18e33fd7578d60d8654469e23530a210618e11 SHA512 72896cc5a677361779f49d60dbdfc33a21d77bd479e0586b0beb03eee2016d613aee56e798143a489431a07a5e7a7db4c7c046105a11b63dd178768f3a7f195a
DIST qtbase-everywhere-src-6.7.1.tar.xz 49324536 BLAKE2B 5e5a5801c29c1ac541812931cd56709a934a500ce4d5a38e7d3776620cb46db0d25408c22cbf33a7bcc657098c571e501fde14f523a77acba1827edd977d2bc5 SHA512 864bebfc3659907e52b8dc3f62a65d431573ef2bf406a9f71c688229083a2128c5474f75823275d11948be3d031de1d6427acf373f977df9ee9e73a27ef56efb
diff --git a/dev-qt/qtbase/files/qtbase-6.7.0-CVE-2024-33861.patch b/dev-qt/qtbase/files/qtbase-6.7.0-CVE-2024-33861.patch
deleted file mode 100644
index 0a73d72..0000000
--- a/dev-qt/qtbase/files/qtbase-6.7.0-CVE-2024-33861.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-https://bugs.gentoo.org/931096
-https://www.qt.io/blog/security-advisory-qstringconverter
-https://codereview.qt-project.org/c/qt/qtbase/+/556191
---- a/src/corelib/text/qstringconverter.cpp
-+++ b/src/corelib/text/qstringconverter.cpp
-@@ -1954,7 +1954,7 @@ struct QStringConverterICU : QStringConverter
- const void *context;
- ucnv_getToUCallBack(icu_conv, &action, &context);
- if (context != state)
-- ucnv_setToUCallBack(icu_conv, action, &state, nullptr, nullptr, &err);
-+ ucnv_setToUCallBack(icu_conv, action, state, nullptr, nullptr, &err);
-
- ucnv_toUnicode(icu_conv, &target, targetLimit, &source, sourceLimit, nullptr, flush, &err);
- // We did reserve enough space:
-@@ -1987,7 +1987,7 @@ struct QStringConverterICU : QStringConverter
- const void *context;
- ucnv_getFromUCallBack(icu_conv, &action, &context);
- if (context != state)
-- ucnv_setFromUCallBack(icu_conv, action, &state, nullptr, nullptr, &err);
-+ ucnv_setFromUCallBack(icu_conv, action, state, nullptr, nullptr, &err);
-
- ucnv_fromUnicode(icu_conv, &target, targetLimit, &source, sourceLimit, nullptr, flush, &err);
- // We did reserve enough space:
diff --git a/dev-qt/qtbase/files/qtbase-6.7.0-qspan-ifdef.patch b/dev-qt/qtbase/files/qtbase-6.7.0-qspan-ifdef.patch
deleted file mode 100644
index 4c2a37c..0000000
--- a/dev-qt/qtbase/files/qtbase-6.7.0-qspan-ifdef.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://bugreports.qt.io/browse/QTBUG-123937
-From 6810220218cbbf2854ecdedb291f7e4a84b31e54 Mon Sep 17 00:00:00 2001
-From: Albert Astals Cid <aacid@kde.org>
-Date: Wed, 3 Apr 2024 00:47:01 +0200
-Subject: [PATCH] Use ifdef instead of if for __cpp_lib_span
-
-Like the other times it's used in this file
-
-This is causing compilation errors in projects that use -Werror=undef
-
-Fixes: QTBUG-123937
-Change-Id: I0cdd2910755dc9079890011dd8dbc27a6e64793e
-Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
-(cherry picked from commit 699ddcb15b5e981d32ea65d1c1a12f8fa0b06e0d)
-Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
---- a/src/corelib/tools/qspan.h
-+++ b/src/corelib/tools/qspan.h
-@@ -297,7 +297,7 @@ public:
- : QSpanBase(il.begin(), il.size())
- {}
-
--#if __cpp_lib_span
-+#ifdef __cpp_lib_span
- template <typename S, size_t N, if_qualification_conversion<S> = true>
- Q_IMPLICIT constexpr QSpanBase(std::span<S, N> other) noexcept
- : QSpanBase(other.data(), other.size())
---
-2.44.0
-
diff --git a/dev-qt/qtbase/qtbase-6.7.0-r2.ebuild b/dev-qt/qtbase/qtbase-6.7.0-r2.ebuild
deleted file mode 100644
index 50d8950..0000000
--- a/dev-qt/qtbase/qtbase-6.7.0-r2.ebuild
+++ /dev/null
@@ -1,384 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic qt6-build toolchain-funcs
-
-DESCRIPTION="Cross-platform application development framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-declare -A QT6_IUSE=(
- [global]="+ssl +udev zstd"
- [core]="icu"
- [modules]="+concurrent +dbus +gui +network +sql +xml"
-
- [gui]="
- +X accessibility eglfs evdev gles2-only +libinput
- opengl renderdoc tslib vulkan wayland +widgets
- "
- [network]="brotli gssapi libproxy sctp"
- [sql]="mysql oci8 odbc postgres +sqlite"
- [widgets]="cups gtk"
-
- [optfeature]="nls" #810802
-)
-IUSE="${QT6_IUSE[*]}"
-REQUIRED_USE="
- $(
- printf '%s? ( gui ) ' ${QT6_IUSE[gui]//+/}
- printf '%s? ( network ) ' ${QT6_IUSE[network]//+/}
- printf '%s? ( sql ) ' ${QT6_IUSE[sql]//+/}
- printf '%s? ( gui widgets ) ' ${QT6_IUSE[widgets]//+/}
- )
- accessibility? ( dbus )
- eglfs? ( opengl )
- gles2-only? ( opengl )
- gui? ( || ( X eglfs wayland ) )
- libinput? ( udev )
- sql? ( || ( ${QT6_IUSE[sql]//+/} ) )
- test? ( icu sql? ( sqlite ) )
-"
-
-# groups:
-# - global (configure.cmake)
-# - qtcore (src/corelib/configure.cmake)
-# - qtgui (src/gui/configure.cmake)
-# - qtnetwork (src/network/configure.cmake)
-# - qtprintsupport (src/printsupport/configure.cmake) [gui+widgets]
-# - qtsql (src/plugins/sqldrivers/configure.cmake)
-# dlopen: renderdoc
-RDEPEND="
- sys-libs/zlib:=
- ssl? ( dev-libs/openssl:= )
- udev? ( virtual/libudev:= )
- zstd? ( app-arch/zstd:= )
-
- app-crypt/libb2
- dev-libs/double-conversion:=
- dev-libs/glib:2
- dev-libs/libpcre2:=[pcre16,unicode(+)]
- icu? ( dev-libs/icu:= )
-
- dbus? ( sys-apps/dbus )
- gui? (
- media-libs/fontconfig
- media-libs/freetype:2
- media-libs/harfbuzz:=
- media-libs/libjpeg-turbo:=
- media-libs/libpng:=
- x11-libs/libdrm
- x11-libs/libxkbcommon[X?]
- X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libxcb:=
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- accessibility? ( app-accessibility/at-spi2-core:2 )
- eglfs? ( media-libs/mesa[gbm(+)] )
- evdev? ( sys-libs/mtdev )
- libinput? ( dev-libs/libinput:= )
- opengl? (
- gles2-only? ( media-libs/libglvnd )
- !gles2-only? ( media-libs/libglvnd[X?] )
- )
- renderdoc? ( media-gfx/renderdoc )
- tslib? ( x11-libs/tslib )
- widgets? (
- cups? ( net-print/cups )
- gtk? (
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- )
- )
- )
- network? (
- brotli? ( app-arch/brotli:= )
- gssapi? ( virtual/krb5 )
- libproxy? ( net-libs/libproxy )
- )
- sql? (
- mysql? ( dev-db/mysql-connector-c:= )
- oci8? ( dev-db/oracle-instantclient:=[sdk] )
- odbc? ( dev-db/unixODBC )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( dev-db/sqlite:3 )
- )
-"
-DEPEND="
- ${RDEPEND}
- X? ( x11-base/xorg-proto )
- gui? (
- vulkan? ( dev-util/vulkan-headers )
- )
- network? (
- sctp? ( net-misc/lksctp-tools )
- )
- test? (
- elibc_musl? ( sys-libs/timezone-data )
- )
-"
-BDEPEND="zstd? ( app-arch/libarchive[zstd] )" #910392
-PDEPEND="
- nls? ( ~dev-qt/qttranslations-${PV}:6 )
- wayland? ( ~dev-qt/qtwayland-${PV}:6 )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.6.0-libressl.patch
- "${FILESDIR}"/${PN}-6.5.2-hppa-forkfd-grow-stack.patch
- "${FILESDIR}"/${PN}-6.5.2-no-symlink-check.patch
- "${FILESDIR}"/${PN}-6.6.1-forkfd-childstack-size.patch
- "${FILESDIR}"/${PN}-6.6.3-gcc14-avx512fp16.patch
- "${FILESDIR}"/${PN}-6.6.3-pkgconf-deps.patch
- "${FILESDIR}"/${PN}-6.7.0-qspan-ifdef.patch
- "${FILESDIR}"/${PN}-6.7.0-CVE-2024-33861.patch
-)
-
-src_prepare() {
- qt6-build_src_prepare
-
- if use test; then
- # test itself has -Werror=strict-aliasing issues, drop for simplicity
- sed -e '/add_subdirectory(qsharedpointer)/d' \
- -i tests/auto/corelib/tools/CMakeLists.txt || die
-
- # workaround for __extendhfxf2 being used for tst_qfloat16.cpp
- # which is unavailable with compiler-rt (assume used if clang)
- if tc-is-clang; then
- sed -e '/add_subdirectory(qfloat16)/d' \
- -i tests/auto/corelib/global/CMakeLists.txt || die
- fi
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_WITH_PCH=OFF
-
- -DINSTALL_ARCHDATADIR="${QT6_ARCHDATADIR}"
- -DINSTALL_BINDIR="${QT6_BINDIR}"
- -DINSTALL_DATADIR="${QT6_DATADIR}"
- -DINSTALL_DOCDIR="${QT6_DOCDIR}"
- -DINSTALL_EXAMPLESDIR="${QT6_EXAMPLESDIR}"
- -DINSTALL_INCLUDEDIR="${QT6_HEADERDIR}"
- -DINSTALL_LIBDIR="${QT6_LIBDIR}"
- -DINSTALL_LIBEXECDIR="${QT6_LIBEXECDIR}"
- -DINSTALL_MKSPECSDIR="${QT6_MKSPECSDIR}"
- -DINSTALL_PLUGINSDIR="${QT6_PLUGINDIR}"
- -DINSTALL_QMLDIR="${QT6_QMLDIR}"
- -DINSTALL_SYSCONFDIR="${QT6_SYSCONFDIR}"
- -DINSTALL_TRANSLATIONSDIR="${QT6_TRANSLATIONDIR}"
-
- -DQT_UNITY_BUILD=ON # ~30% faster build, affects other dev-qt/* too
-
- -DQT_FEATURE_relocatable=OFF #927691
- $(qt_feature ssl openssl)
- $(qt_feature ssl openssl_linked)
- $(qt_feature udev libudev)
- $(qt_feature zstd)
-
- # qtcore
- $(qt_feature icu)
-
- # tools
- -DQT_FEATURE_androiddeployqt=OFF
-
- # modules
- $(qt_feature concurrent)
- $(qt_feature dbus)
- $(qt_feature gui)
- $(qt_feature network)
- $(qt_feature sql)
- # trivial, and is often needed (sometimes even when not building tests)
- -DQT_FEATURE_testlib=ON
- $(qt_feature xml)
- )
-
- use gui && mycmakeargs+=(
- $(qt_feature X xcb)
- $(qt_feature X system_xcb_xinput)
- $(qt_feature X xkbcommon_x11)
- $(cmake_use_find_package X X11) # needed for truly no automagic
- $(qt_feature accessibility accessibility_atspi_bridge)
- $(qt_feature eglfs)
- $(qt_feature evdev)
- $(qt_feature evdev mtdev)
- $(qt_feature libinput)
- $(qt_feature renderdoc graphicsframecapture)
- $(qt_feature tslib)
- $(qt_feature vulkan)
- $(qt_feature wayland)
- $(qt_feature widgets)
- -DINPUT_opengl=$(usex opengl $(usex gles2-only es2 desktop) no)
- -DQT_FEATURE_system_textmarkdownreader=OFF # TODO?: package md4c
- ) && use widgets && mycmakeargs+=(
- # note: qtprintsupport is enabled w/ gui+widgets regardless of USE=cups
- $(qt_feature cups)
- $(qt_feature gtk gtk3)
- )
-
- use network && mycmakeargs+=(
- $(qt_feature brotli)
- $(qt_feature gssapi)
- $(qt_feature libproxy)
- $(qt_feature sctp)
- $(usev test -DQT_SKIP_DOCKER_COMPOSE=ON)
- -DQT_FEATURE_dtls=OFF # Required for LibreSSL
- )
-
- use sql && mycmakeargs+=(
- -DQT_FEATURE_sql_db2=OFF # unpackaged
- -DQT_FEATURE_sql_ibase=OFF # unpackaged
- -DQT_FEATURE_sql_mimer=OFF # unpackaged
- $(qt_feature mysql sql_mysql)
- $(qt_feature oci8 sql_oci)
- $(usev oci8 -DOracle_ROOT="${ESYSROOT}"/usr/$(get_libdir)/oracle/client)
- $(qt_feature odbc sql_odbc)
- $(qt_feature postgres sql_psql)
- $(qt_feature sqlite sql_sqlite)
- $(qt_feature sqlite system_sqlite)
- )
-
- if use amd64 || use x86; then
- # see bug #913400 for explanations
- local cpufeats=(
- # list of checked cpu features in configure.cmake
- avx avx2 avx512{bw,cd,dq,er,f,ifma,pf,vbmi,vbmi2,vl}
- f16c rdrnd rdseed sse2 sse3 sse4_1 sse4_2 ssse3 vaes
- )
- # handle odd ones out not matching -m* and macros (keep same order)
- local cpuflags=( "${cpufeats[@]}" aes sha )
- local cpufeats+=( aesni shani )
-
- local -a intrins
- IFS=' ' read -ra intrins < <(
- : "$(test-flags-CXX "${cpuflags[@]/#/-m}")"
- $(tc-getCXX) -E -P ${_} ${CXXFLAGS} ${CPPFLAGS} - <<-EOF | tail -n 1
- $(printf '__%s__ ' "${cpuflags[@]^^}")
- EOF
- assert
- )
-
- # do nothing and leave to qtbase if no macros expanded (test failed?)
- if [[ \ ${intrins[*]} == *\ [^_\ ]* ]]; then
- local -i i
- for ((i=0; i<${#cpufeats[@]}; i++)); do
- [[ ${intrins[i]} == __* ]] &&
- mycmakeargs+=( -DQT_FEATURE_${cpufeats[i]}=OFF )
- done
- mycmakeargs+=( -DTEST_x86intrin=ON )
- fi
- fi
-
- qt6-build_src_configure
-}
-
-src_test() {
- local -x TZ=UTC
- local -x LC_TIME=C
-
- local CMAKE_SKIP_TESTS=(
- # broken with out-of-source + if qtbase is not already installed
- tst_moc
- tst_qmake
- # similarly broken when relocatable=OFF (bug #927691)
- tst_qapplication
- tst_qt_cmake_create
- tst_uic
- # needs x11/opengl, we *could* run these but tend to be flaky
- # when opengl rendering is involved (even if software-only)
- tst_qopengl{,config,widget,window}
- tst_qgraphicsview
- tst_qx11info
- # fails with network sandbox
- tst_qdnslookup
- # fails with sandbox
- tst_qsharedmemory
- # typical to lack SCTP support on non-generic kernels
- tst_qsctpsocket
- # randomly fails without -j1, and not worth it over this (bug #916181)
- tst_qfiledialog{,2}
- # may randomly hang+timeout, perhaps related to -j as well
- tst_qtimer
- # these can be flaky depending on the environment/toolchain
- tst_qlogging # backtrace log test can easily vary
- tst_q{,raw}font # affected by available fonts / settings (bug #914737)
- tst_qprinter # checks system's printers (bug #916216)
- tst_qstorageinfo # checks mounted filesystems
- # flaky due to using different test framework and fails with USE=-gui
- tst_selftests
- # known failing when using clang+glibc+stdc++, needs looking into
- tst_qthread
- # partially failing on x86 chroots and seemingly(?) harmless (dev-qt
- # revdeps tests pass), skip globally to avoid keywording flakiness
- tst_json
- tst_qcolorspace
- tst_qdoublevalidator
- tst_qglobal
- tst_qglyphrun
- tst_qvectornd
- tst_rcc
- # similarly, but on armv7 and potentially others (bug #914028)
- tst_qlineedit
- tst_qpainter
- # likewise, known failing on BE arches (bug #914033,914371,918878)
- tst_qimagereader
- tst_qimagewriter
- tst_qpluginloader
- tst_quuid # >=6.6.2 had related fixes, needs retesting
- # partially broken on llvm-musl, needs looking into but skip to have
- # a baseline for regressions (rest of dev-qt still passes with musl)
- $(usev elibc_musl '
- tst_qicoimageformat
- tst_qimagereader
- tst_qimage
- tst_qprocess
- ')
- # fails due to hppa's NaN handling, needs looking into (bug #914371)
- $(usev hppa '
- tst_qcborvalue
- tst_qnumeric
- ')
- # bug #914033
- $(usev sparc '
- tst_qbuffer
- tst_qprocess
- tst_qtconcurrentiteratekernel
- ')
- # note: for linux, upstream only really runs+maintains tests for amd64
- # https://doc.qt.io/qt-6/supported-platforms.html
- )
-
- qt6-build_src_test
-}
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- local delete_bins=( # need a better way to handle this
- clientserver copier crashingServer desktopsettingsaware_helper
- echo fileWriterProcess modal_helper nospace 'one space'
- paster qcommandlineparser_test_helper qfileopeneventexternal
- socketprocess syslocaleapp tst_qhashseed_helper 'two space s'
- write-read-write
- )
- local delete=( # sigh
- "${D}${QT6_BINDIR}"/test*
- "${delete_bins[@]/#/${D}${QT6_BINDIR}/}"
- )
- # using -f given not tracking which tests may be skipped or not
- rm -rf -- "${delete[@]}" || die
- fi
-}