aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/cyclonedds/cyclonedds-9999.ebuild')
-rw-r--r--sys-libs/cyclonedds/cyclonedds-9999.ebuild45
1 files changed, 17 insertions, 28 deletions
diff --git a/sys-libs/cyclonedds/cyclonedds-9999.ebuild b/sys-libs/cyclonedds/cyclonedds-9999.ebuild
index fbdaecca1..14cd2e34b 100644
--- a/sys-libs/cyclonedds/cyclonedds-9999.ebuild
+++ b/sys-libs/cyclonedds/cyclonedds-9999.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
-
if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/eclipse-cyclonedds/"
+ EGIT_REPO_URI="https://github.com/eclipse-cyclonedds/cyclonedds.git"
inherit git-r3
-
else
-
SRC_URI="https://github.com/eclipse-cyclonedds/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
S="${WORKDIR}/${P}"
-DESCRIPTION="Eclipse Cyclone DDS is a very performant and robust open-source implementation of the OMG DDS specification."
+DESCRIPTION="Eclipse Cyclone DDS project"
HOMEPAGE="https://cyclonedds.io/"
LICENSE="EPL-2.0"
SLOT="0/$(ver_cut 1-2)"
-IUSE="test ssl shm parser doc examples ipv6 idlc get_kind"
+IUSE="test ssl shm parser doc examples ipv6 idlc get-kind"
RESTRICT="!test? ( test )"
RDEPEND=(
@@ -33,34 +30,26 @@ RDEPEND=(
)
DEPEND="${RDEPEND[@]}"
-
CMAKE_BUILD_TYPE=Release
-#PATCHES=()
-
-src_prepare() {
- use get_kind && eapply ${FILESDIR}/${PN}-0.10.3-get_kind.patch
+src_prepare() {
+ use get_kind && eapply "${FILESDIR}/${PN}-0.10.3-get_kind.patch"
cmake_src_prepare
}
src_configure() {
-
local mycmakeargs=(
- -DBUILD_DOCS= $(usex doc)
- -DBUILD_DDSPERF=OFF
- -DBUILD_EXAMPLES=$(usex examples)
-
-
- -DBUILD_TESTING=$(usex test)
- -DBUILD_IDLC_TESTING=$(usex test)
-
- -DBUILD_IDLC=$(usex idlc)
- -DENABLE_SSL=$(usex ssl)
- -DENABLE_SECURITY=$(usex ssl)
- -DENABLE_SECURITY=$(usex ssl)
- -DENABLE_IPV6=$(usex ipv6)
- -DENABLE_SHM=$(usex shm)
+ -DBUILD_DOCS= $(usex doc)
+ -DBUILD_DDSPERF=OFF
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_IDLC_TESTING=$(usex test)
+ -DBUILD_IDLC=$(usex idlc)
+ -DENABLE_SSL=$(usex ssl)
+ -DENABLE_SECURITY=$(usex ssl)
+ -DENABLE_SECURITY=$(usex ssl)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_SHM=$(usex shm)
)
-
cmake_src_configure
}