aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/discover-overlay/discover-overlay-0.3.3.ebuild')
-rw-r--r--net-voip/discover-overlay/discover-overlay-0.3.3.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-voip/discover-overlay/discover-overlay-0.3.3.ebuild b/net-voip/discover-overlay/discover-overlay-0.3.3.ebuild
index 6cdd877fc..552d39f48 100644
--- a/net-voip/discover-overlay/discover-overlay-0.3.3.ebuild
+++ b/net-voip/discover-overlay/discover-overlay-0.3.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="Yet another Discord overlay for Linux written in Python using GTK3."
+DESCRIPTION="Yet another Discord overlay for Linux written in Python using GTK3"
HOMEPAGE="https://github.com/trigg/Discover"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -15,9 +15,9 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND=">=dev-python/pygobject-3.22
- dev-python/websocket-client
- dev-python/pyxdg
- dev-python/requests
- >=dev-python/python-pidfile-3.0.0
- dev-python/pillow"
+RDEPEND=">=dev-python/pygobject-3.22[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/python-pidfile-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"