aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/wivrn/wivrn-0.13.ebuild')
-rw-r--r--media-libs/wivrn/wivrn-0.13.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/wivrn/wivrn-0.13.ebuild b/media-libs/wivrn/wivrn-0.13.ebuild
index a6e984eab..af71a4563 100644
--- a/media-libs/wivrn/wivrn-0.13.ebuild
+++ b/media-libs/wivrn/wivrn-0.13.ebuild
@@ -1,15 +1,15 @@
EAPI=7
+inherit cmake
+
DESCRIPTION="WiVRn OpenXR streaming"
HOMEPAGE="https://github.com/meumeu/WiVRn"
-SLOT="0"
-LICENSE="GPL-3 Apache-2.0 MIT"
+LICENSE="GPL-3 Apache-2.0 MIT"
+SLOT="0"
IUSE="nvenc pipewire pulseaudio systemd vaapi wireshark-plugins x264"
REQUIRED_USE="|| ( nvenc vaapi x264 )"
-inherit cmake
-
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Meumeu/WiVRn.git"
@@ -99,7 +99,7 @@ src_configure() {
-DWIVRN_USE_SYSTEMD=$(usex systemd)
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON
-DFETCHCONTENT_FULLY_DISCONNECTED=ON
- -DFETCHCONTENT_BASE_DIR=${WORKDIR}
+ -DFETCHCONTENT_BASE_DIR="${WORKDIR}"
-DENABLE_COLOURED_OUTPUT=OFF
)