aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/sfwbar/sfwbar-1.0_beta9.ebuild')
-rw-r--r--gui-apps/sfwbar/sfwbar-1.0_beta9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gui-apps/sfwbar/sfwbar-1.0_beta9.ebuild b/gui-apps/sfwbar/sfwbar-1.0_beta9.ebuild
new file mode 100644
index 000000000..60d43643e
--- /dev/null
+++ b/gui-apps/sfwbar/sfwbar-1.0_beta9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Sway Floating Window Bar"
+HOMEPAGE="https://github.com/LBCrion/sfwbar"
+SRC_URI="https://github.com/LBCrion/sfwbar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
+ gui-libs/gtk-layer-shell
+ dev-libs/json-c
+ dev-util/wayland-scanner
+ >=dev-libs/wayland-protocols-1.17
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"