aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cmark-gfm/cmark-gfm-0.29.0.0.ebuild')
-rw-r--r--app-text/cmark-gfm/cmark-gfm-0.29.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/cmark-gfm/cmark-gfm-0.29.0.0.ebuild b/app-text/cmark-gfm/cmark-gfm-0.29.0.0.ebuild
new file mode 100644
index 000000000..386e2c8db
--- /dev/null
+++ b/app-text/cmark-gfm/cmark-gfm-0.29.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYPV="$(ver_rs 3 '.gfm.')"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="GitHub's fork of cmark"
+HOMEPAGE="https://github.com/github/cmark-gfm"
+SRC_URI="https://github.com/github/cmark-gfm/archive/${MYPV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MYPV}"
+LICENSE="BSD-2"
+SLOT="0/0.29.0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}