aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/fuse-archive/fuse-archive-0.1.14.ebuild')
-rw-r--r--app-arch/fuse-archive/fuse-archive-0.1.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/fuse-archive/fuse-archive-0.1.14.ebuild b/app-arch/fuse-archive/fuse-archive-0.1.14.ebuild
new file mode 100644
index 000000000..a57506a3e
--- /dev/null
+++ b/app-arch/fuse-archive/fuse-archive-0.1.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Read-only FUSE file system for mounting archives and compressed files"
+HOMEPAGE="https://github.com/google/fuse-archive"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/fuse-archive.git"
+else
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ sys-fs/fuse:0
+ app-arch/libarchive
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin out/fuse-archive
+}
+
+# TODO(NRK): enable tests