aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-04-23 14:04:29 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-04-23 14:04:29 +0200
commit7bc16263f88dbf01328625af814b277b722f8e10 (patch)
tree6f09c7e69799d45c70470c40836e14d8be683c51 /sys-libs
parentacct-user/sndiod: add KEYWORS (diff)
downloadguru-7bc16263f88dbf01328625af814b277b722f8e10.tar.gz
guru-7bc16263f88dbf01328625af814b277b722f8e10.tar.bz2
guru-7bc16263f88dbf01328625af814b277b722f8e10.zip
sys-libs/solo-udev-rules: Revbump 4.0.0-r1; Add missing pkg_postrm().
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/solo-udev-rules/solo-udev-rules-4.0.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/solo-udev-rules/solo-udev-rules-4.0.0-r1.ebuild b/sys-libs/solo-udev-rules/solo-udev-rules-4.0.0-r1.ebuild
new file mode 100644
index 000000000..8accaf74a
--- /dev/null
+++ b/sys-libs/solo-udev-rules/solo-udev-rules-4.0.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+MY_P="solo-${PV}"
+DESCRIPTION="udev rules for the Solo FIDO2 & U2F USB+NFC security key"
+HOMEPAGE="
+ https://solokeys.com/
+ https://github.com/solokeys/solo
+"
+SRC_URI="https://github.com/solokeys/solo/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # Omitting src_compile() would invoke make, leaving it empty is not allowed.
+ echo -n
+}
+
+src_install() {
+ udev_dorules udev/70-solokeys-access.rules
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}