aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Postiglione <andrea.postiglione@gmail.com>2020-12-08 17:51:44 +0100
committerAndrea Postiglione <andrea.postiglione@gmail.com>2020-12-08 17:51:44 +0100
commit047edc4a90453a663c71cc93221021e300152efc (patch)
treeb5fe1b580265955cbd5f37ab66c841cf85050779 /sys-cluster/pcs
parentdev-python/mkdocs-*: moved to ::gentoo (diff)
downloadguru-047edc4a90453a663c71cc93221021e300152efc.tar.gz
guru-047edc4a90453a663c71cc93221021e300152efc.tar.bz2
guru-047edc4a90453a663c71cc93221021e300152efc.zip
sys-cluster/pcs: fix use systemd useflag
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrea Postiglione <andrea.postiglione@gmail.com>
Diffstat (limited to 'sys-cluster/pcs')
-rw-r--r--sys-cluster/pcs/pcs-0.10.7.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-cluster/pcs/pcs-0.10.7.ebuild b/sys-cluster/pcs/pcs-0.10.7.ebuild
index 2811b60e7..6e2acc6bc 100644
--- a/sys-cluster/pcs/pcs-0.10.7.ebuild
+++ b/sys-cluster/pcs/pcs-0.10.7.ebuild
@@ -87,8 +87,10 @@ src_install() {
dosym ../../sbin/pcs "${EPREFIX}/usr/lib/pcs/pcs"
# use Debian style systemd unit (with config in /etc/default/pcsd)
- systemd_newunit "${S}/pcsd/pcsd.service.debian" "pcsd.service"
- systemd_newunit "${S}/pcsd/pcsd-ruby.service" "pcsd-daemon.service"
+ if use systemd ; then
+ systemd_newunit "${S}/pcsd/pcsd.service.debian" "pcsd.service"
+ systemd_newunit "${S}/pcsd/pcsd-ruby.service" "pcsd-daemon.service"
+ fi
# custom service file for openRC
newinitd "${FILESDIR}/pcsd.initd" pcsd || die
newinitd "${FILESDIR}/pcsd-daemon.initd" pcsd-daemon || die