aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-11-06 12:53:35 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-11-06 12:54:06 +0100
commita4cd697f4722e58052066eec79b5e673bb9dd08a (patch)
tree07079ba8611a123e78e77a134ee31b5d677b307d /sys-boot
parentnet-vpn/mullvadvpn-app: Add openrc service for mullvad-daemon (diff)
downloadguru-a4cd697f4722e58052066eec79b5e673bb9dd08a.tar.gz
guru-a4cd697f4722e58052066eec79b5e673bb9dd08a.tar.bz2
guru-a4cd697f4722e58052066eec79b5e673bb9dd08a.zip
sys-boot/limine: add rv64 support
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/limine-5.20231103.0-r1.ebuild44
-rw-r--r--sys-boot/limine/metadata.xml3
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-boot/limine/limine-5.20231103.0-r1.ebuild b/sys-boot/limine/limine-5.20231103.0-r1.ebuild
new file mode 100644
index 000000000..73ea27214
--- /dev/null
+++ b/sys-boot/limine/limine-5.20231103.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ TOOLCHAIN_FOR_TARGET=llvm \
+ econf "${myconf[@]}"
+}
diff --git a/sys-boot/limine/metadata.xml b/sys-boot/limine/metadata.xml
index a8b550563..ddb789d21 100644
--- a/sys-boot/limine/metadata.xml
+++ b/sys-boot/limine/metadata.xml
@@ -18,6 +18,9 @@
<flag name="uefiaa64">
Enable AArch64 UEFI support.
</flag>
+ <flag name="uefirv64">
+ Enable 64-bit RISC-V UEFI support.
+ </flag>
<flag name="cd-efi">
Enable building cd-efi.bin using <pkg>sys-fs/mtools</pkg>.
This flag was previously known as eltorito-efi.