aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-03-08 10:35:10 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-03-08 10:35:27 +0100
commit5aa73e62c205043bdda0eacb5730a808cc488346 (patch)
tree7bb60ea430e11760be0fa73b4e469154085dd6ea /sys-boot
parentdev-python/readmdict: enable py3.11 (diff)
downloadguru-5aa73e62c205043bdda0eacb5730a808cc488346.tar.gz
guru-5aa73e62c205043bdda0eacb5730a808cc488346.tar.bz2
guru-5aa73e62c205043bdda0eacb5730a808cc488346.zip
sys-boot/limine: add 4.20230307.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-4.20230307.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 7096414e3..156d13cf1 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -9,3 +9,4 @@ DIST limine-4.20230219.0.tar.xz 782172 BLAKE2B 525308e0ccfbce2814b7fb497023d7e2e
DIST limine-4.20230221.0.tar.xz 782956 BLAKE2B 29edaae0698b7d3ce9a1a3b7b1ce9e28402294681121b30f7d7b3359a2da2bffa0037e94393c7137caae8008e1f4d88a226cc36d50b4a0b20e8433d7bd75f678 SHA512 99d9341ffa2e2906d4d5086bc2d27ba217bfd68742bc6ee734734d8c75f9eee2b761b84e622e76f14a87b2128105cefe42dca330441f43ecd4d210670176da91
DIST limine-4.20230227.0.tar.xz 782796 BLAKE2B 35819ccfe896f595a10b666bc0a8d665ea6948f5ea3509833d05a81e574f6c9009a120773e28bc2f4d4d2172926f20796083b62e0ac153f8a232f20d21c6a945 SHA512 621bb2ddb25de88df63f73852e2ff6ceccc61d7d4be49ee8c0cf614c5037f37d350ff50d924065f5f5e6295dc5e99d53191db55778384c15c580630c32cbc560
DIST limine-4.20230305.2.tar.xz 783156 BLAKE2B 0a030a8ed3b1cef212adf94ba22d3e599b7cbae61551e374c9139fb6a2c02eae6c6f3241cebf220f877df91c0e9fc1b4f0cbafa35d4fe3fa32b380df50b9528a SHA512 6adb0054f512710752667419a08439175e63297794a9c88eaad92a20c54abfbc45636ecac10302db3a4956469d2c1b8608495ef60b51888fef7c2f0da8843d25
+DIST limine-4.20230307.0.tar.xz 783112 BLAKE2B 108340d15aca9954c22bf78e2abcc1d1f65036cfbc37247385b77565146a96a405884d8d7c9d3999785090b8d980d6c3b17c3d658b7381ffba3f57cfff57bbcf SHA512 55de1d592157e4227caca6191b764c5a093208d3ba02b23e4fc03f7f132b86cc9984b0bae084fa909506cd9ff4c29f8fdb628699e34511389be12e7e46bd52c2
diff --git a/sys-boot/limine/limine-4.20230307.0.ebuild b/sys-boot/limine/limine-4.20230307.0.ebuild
new file mode 100644
index 000000000..26329c4d3
--- /dev/null
+++ b/sys-boot/limine/limine-4.20230307.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64"
+
+MY_LLVM_TARGETS="AArch64 ARM X86"
+MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ sys-devel/clang[${MY_LLVM_FLAGS}]
+ sys-devel/lld
+ sys-devel/llvm[${MY_LLVM_FLAGS}]
+
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+
+ "$(use_enable uefi32 uefi-ia32)"
+ "$(use_enable uefi64 uefi-x86-64)"
+ "$(use_enable uefiaa64 uefi-aarch64)"
+ "$(use_enable cd-efi uefi-cd)"
+ )
+
+ CROSS_TOOLCHAIN=llvm \
+ econf "${myconf[@]}"
+}