aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-06-29 07:58:45 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-06-29 08:18:05 +0500
commit2689500ac233863830d600ce6058be3594226f02 (patch)
treeb3aef510850a3f6d55d057e41343ebf26cbf16e2 /sys-boot
parentmpv-plugin/SimpleUndo: new package (diff)
downloadguru-2689500ac233863830d600ce6058be3594226f02.tar.gz
guru-2689500ac233863830d600ce6058be3594226f02.tar.bz2
guru-2689500ac233863830d600ce6058be3594226f02.zip
sys-boot/woeusb-ng: add 0.2.12
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/woeusb-ng/Manifest1
-rw-r--r--sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-postinstall.patch9
-rw-r--r--sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild53
3 files changed, 63 insertions, 0 deletions
diff --git a/sys-boot/woeusb-ng/Manifest b/sys-boot/woeusb-ng/Manifest
index adc847359..88a05b9e0 100644
--- a/sys-boot/woeusb-ng/Manifest
+++ b/sys-boot/woeusb-ng/Manifest
@@ -1 +1,2 @@
DIST woeusb-ng-0.2.10.tar.gz 213600 BLAKE2B 384d4e93eff97c3b953770247b18409c8f611c9fe72a3292ed69e1d4ba12bf02018336adc5fcceeb8a59b494380816bfe75a571818ec44b1311f6ce02afa478b SHA512 3fd3ad3c725aabf86ead18cde7a812d97dee81ada5830e91548bd4033bba94a2b77085d00b1972d999e5cc9978ee58d74d8b376a04fd7d6ce47c44c749c9d6a8
+DIST woeusb-ng-0.2.12.tar.gz 219102 BLAKE2B d146697ce4143adc62b489a5dbd09bd2dd02d910a51357a27b1a92663eee279c6fa3bdd39b0f01e46f445cb0170c3b0dbf37ed7fdc442386247ff2acb85791e8 SHA512 3323d1f33f3c009652555ca20827d3ab902a59c21b4e57725ac7efb702c60c8ab8a572f77c7f5e4da91713ea5412811358870d6100e13e5828421645b7464c38
diff --git a/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-postinstall.patch b/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-postinstall.patch
new file mode 100644
index 000000000..6151cf721
--- /dev/null
+++ b/sys-boot/woeusb-ng/files/woeusb-ng-0.2.12-postinstall.patch
@@ -0,0 +1,9 @@
+--- a/setup.py
++++ b/setup.py
+@@ -68,6 +68,5 @@ setup(
+ ],
+ cmdclass={
+ 'develop': PostDevelopCommand,
+- 'install': PostInstallCommand
+ }
+ )
diff --git a/sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild b/sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild
new file mode 100644
index 000000000..e7664311b
--- /dev/null
+++ b/sys-boot/woeusb-ng/woeusb-ng-0.2.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+#
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit desktop distutils-r1 optfeature xdg
+
+MY_PN="WoeUSB-ng"
+DESCRIPTION="Create Windows installer USB from ISO (rewrite of WoeUSB)"
+HOMEPAGE="https://github.com/WoeUSB/WoeUSB-ng"
+SRC_URI="https://github.com/WoeUSB/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !sys-boot/woeusb
+ app-arch/p7zip
+ $(python_gen_cond_dep '
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ ')
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.12-postinstall.patch )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ python_fix_shebang WoeUSB
+}
+
+src_install() {
+ distutils-r1_src_install
+ dobin WoeUSB/woeusbgui
+
+ insinto /usr/share/polkit-1/actions
+ doins miscellaneous/com.github.woeusb.woeusb-ng.policy
+
+ doicon -s 256 WoeUSB/data/woeusb-logo.png
+ make_desktop_entry woeusbgui WoeUSB-ng woeusb-logo Utility
+}
+
+pkg_postinst() {
+ optfeature "GUI support" dev-python/wxpython:4.0
+ optfeature "Legacy PC bootmode support" "sys-boot/grub[grub_platforms_pc]"
+
+ xdg_pkg_postinst
+}