aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-07-14 11:49:47 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-07-15 13:53:59 +0500
commitd28640db2146cc1a082b7572c0a11a9dea8c35f1 (patch)
treec2bbda5e472cd7734ec8026053c739d8e94c43e8 /sci-misc
parentapp-misc/ssmtool: bump to 0.1.11, fix deps (diff)
downloadguru-d28640db2146cc1a082b7572c0a11a9dea8c35f1.tar.gz
guru-d28640db2146cc1a082b7572c0a11a9dea8c35f1.tar.bz2
guru-d28640db2146cc1a082b7572c0a11a9dea8c35f1.zip
sci-misc/boinc-wrapper: add 7.16.17
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc-wrapper/Manifest1
-rw-r--r--sci-misc/boinc-wrapper/boinc-wrapper-7.16.17.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-misc/boinc-wrapper/Manifest b/sci-misc/boinc-wrapper/Manifest
index 5238eec52f..909891f1be 100644
--- a/sci-misc/boinc-wrapper/Manifest
+++ b/sci-misc/boinc-wrapper/Manifest
@@ -1 +1,2 @@
DIST boinc-7.16.16.tar.gz 49599131 BLAKE2B 819ab85c19a684144711f77e669b892aa73c006b81c1d7ef7adbd9d580e1e8473ae27b52dc17953ee677c70fc78ed15df936afd740e629715f30f2b81d84ea6f SHA512 dd7042e176d6506c70de7866556ae73b2f45734df92038086d5b0414751f3da08dc571c49f0c26d747d3fb2577674d3ff8cdec7d3563861eaaaa5af9c1db0a0e
+DIST boinc-7.16.17.tar.gz 49628624 BLAKE2B 87e266a29506ecaa41fd18a2521b08c291548a4e31f7748001e5214e6f1fada1ded8bb8b559635d4f9c7c256cd7829dcf9132c02448c559d5ceb13524ca42e0f SHA512 e9882f37ad5c83ed020155c8192228322932f83b88ed00d025dcda63bff2dca109ecdcbaf98b48c4522b841f545f32352e5c158ae0a41de0a1f2941ac8135221
diff --git a/sci-misc/boinc-wrapper/boinc-wrapper-7.16.17.ebuild b/sci-misc/boinc-wrapper/boinc-wrapper-7.16.17.ebuild
new file mode 100644
index 0000000000..f25f7d3990
--- /dev/null
+++ b/sci-misc/boinc-wrapper/boinc-wrapper-7.16.17.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PV=$(ver_cut 1-2)
+
+DESCRIPTION="use non-BOINC apps with BOINC"
+HOMEPAGE="https://boinc.berkeley.edu/trac/wiki/WrapperApp"
+
+SRC_URI="https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> boinc-${PV}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/boinc-client_release-${MY_PV}-${PV}/samples/wrapper"
+
+LICENSE="LGPL-3+ regexp-UofT"
+SLOT="0"
+
+RDEPEND="
+ >=sci-misc/boinc-${PV}
+ >=dev-libs/boinc-zip-${PV}
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-$(ver_cut 1-2)-makefile.patch )
+DOCS=( ReadMe.txt job.xml )
+
+src_prepare() {
+ default
+
+ cd ../.. || die
+ eautoreconf
+ bash ./generate_svn_version.sh || die
+}
+
+src_configure() {
+ cd ../.. || die
+ econf --enable-pkg-devel --disable-static --disable-fcgi --without-x
+}
+
+src_compile() {
+ tc-export CC CXX
+ default
+}
+
+src_install() {
+ default
+ newbin wrapper boinc-wrapper
+}