aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Olagbaiye <bqv@fron.io>2022-05-18 20:49:29 +0100
committerTony Olagbaiye <bqv@fron.io>2022-05-18 20:49:29 +0100
commit8cc423598bc4b568aa8a0c92703e035738e9a1f8 (patch)
treef16af896f9a51ea647e60e9efb7f50f515328bc7 /net-misc
parentdev-util/git-bug: unkeyword 9999 for ~amd64, ~arm64, ~x86 (diff)
downloadguru-8cc423598bc4b568aa8a0c92703e035738e9a1f8.tar.gz
guru-8cc423598bc4b568aa8a0c92703e035738e9a1f8.tar.bz2
guru-8cc423598bc4b568aa8a0c92703e035738e9a1f8.zip
net-misc/yacy: update EAPI 6 -> 7
Signed-off-by: Tony Olagbaiye <bqv@fron.io>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yacy/yacy-1.924.20210209.10069.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/net-misc/yacy/yacy-1.924.20210209.10069.ebuild b/net-misc/yacy/yacy-1.924.20210209.10069.ebuild
index f63c6934b..b85b112cf 100644
--- a/net-misc/yacy/yacy-1.924.20210209.10069.ebuild
+++ b/net-misc/yacy/yacy-1.924.20210209.10069.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit java-pkg-2 java-ant-2 systemd versionator user
+inherit java-pkg-2 java-ant-2 systemd
-MAJOR_PV="$(get_version_component_range 1-2)"
-REL_PV="$(get_version_component_range 3)"
-SVN_PV="$(get_version_component_range 4)"
+MAJOR_PV="$(ver_cut 1-2)"
+REL_PV="$(ver_cut 3)"
+SVN_PV="$(ver_cut 4)"
DESCRIPTION="YaCy - p2p based distributed web-search engine"
HOMEPAGE="https://www.yacy.net/"
@@ -26,11 +26,6 @@ S="${WORKDIR}/${PN}"
EANT_BUILD_TARGET="all"
UNINSTALL_IGNORE="/usr/share/yacy/DATA"
-pkg_setup() {
- enewgroup yacy
- enewuser yacy -1 -1 /var/lib/yacy yacy
-}
-
src_install() {
# remove win-only stuff
find "${S}" -name "*.bat" -exec rm '{}' \; || die
@@ -42,7 +37,7 @@ src_install() {
dodoc AUTHORS NOTICE && rm AUTHORS NOTICE COPYRIGHT gpl.txt
- yacy_home="${EROOT}usr/share/${PN}"
+ yacy_home="${EROOT}/usr/share/${PN}"
dodir ${yacy_home}
cp -r ${S}/* ${D}${yacy_home} || die
@@ -58,8 +53,7 @@ src_install() {
use openrc && {
exeinto /etc/init.d
newexe "${FILESDIR}/yacy.rc" yacy
- insinto /etc/conf.d
- newins "${FILESDIR}/yacy.confd" yacy
+ doconfd "${FILESDIR}/yacy.confd"
}
use systemd && systemd_newunit "${FILESDIR}"/${PN}-ipv6.service ${PN}.service