aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-12 15:11:10 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-12 15:11:10 +0500
commit145212f44fcfb8923d6a1994b6e20e53d18ee292 (patch)
tree362f2c52df4a30bc79088ca7e2946ba7952ce193 /net-irc
parentdev-libs/feedbackd-device-themes: add 0.1.0 (diff)
downloadguru-145212f44fcfb8923d6a1994b6e20e53d18ee292.tar.gz
guru-145212f44fcfb8923d6a1994b6e20e53d18ee292.tar.bz2
guru-145212f44fcfb8923d6a1994b6e20e53d18ee292.zip
net-irc/pounce: add 3.1
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/pounce/Manifest1
-rw-r--r--net-irc/pounce/pounce-3.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-irc/pounce/Manifest b/net-irc/pounce/Manifest
index e69a997fa..63edbe1f3 100644
--- a/net-irc/pounce/Manifest
+++ b/net-irc/pounce/Manifest
@@ -1 +1,2 @@
DIST pounce-3.0.tar.gz 50497 BLAKE2B 2c86ca02110b5bcfdcfa8d2a1fd75c804a64c382fc428550a5d8cd2489c60ecfffac55fa01cd6a6f9f0347ac64d6fe599c454c77e0247e26d9661ac47a2196ce SHA512 76fce4820c877202720505a96d45394027d88f9755fe9a96fb69e305699022d61f8dba7db524b0bc5058b5f999bcd02b82904525d3284b34a29ffbe64c1c3bc0
+DIST pounce-3.1.tar.gz 50801 BLAKE2B f18a6a347a8332ce3ffdb43dc5a6f0b2ef0a533e9a3b7b451c9834c93f6e030ba27382a3c6a39e793df94f4b6c9f196ba3c9e5b4a97f84e60c08fa0c26ee3e61 SHA512 b2c2481e152368080e6ce9b3be2d7920eb4cac630dabb994e31170fb44977e2235c0ff30a7f08e826a329da69371a3ff2dae33831cb93b18655f98fc6569da7d
diff --git a/net-irc/pounce/pounce-3.1.ebuild b/net-irc/pounce/pounce-3.1.ebuild
new file mode 100644
index 000000000..1a26d25bc
--- /dev/null
+++ b/net-irc/pounce/pounce-3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Multi-client, TLS-only IRC bouncer"
+HOMEPAGE="https://git.causal.agency/pounce/about/"
+SRC_URI="https://git.causal.agency/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="palaver"
+
+DEPEND="
+ dev-libs/libretls:=
+ virtual/libcrypt:=
+ palaver? (
+ dev-db/sqlite:3
+ net-misc/curl
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( {QUIRKS,README}.7 )
+
+src_configure() {
+ tc-export CC
+
+ local confargs=(
+ --enable-notify
+ $(use_enable palaver)
+
+ --prefix="${EPREFIX}/usr"
+ --mandir="${EPREFIX}/usr/share/man"
+ )
+
+ # note: not an autoconf configure script
+ edo ./configure "${confargs[@]}"
+}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+
+ newinitd "${FILESDIR}"/pounce.initd pounce
+ newconfd "${FILESDIR}"/pounce.confd pounce
+
+ insinto /etc/pounce
+ doins "${FILESDIR}"/example.conf
+}