aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-13 08:25:09 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-11-13 10:26:22 +0100
commitcc74b8ca6a4e4c96b87896ecffb68f2d1502b9ea (patch)
treeed17ead9b269fcf04397d58a88947bacd77b28df /net-im
parentdev-python/pywebview: drop 3.5 (diff)
downloadguru-cc74b8ca6a4e4c96b87896ecffb68f2d1502b9ea.tar.gz
guru-cc74b8ca6a4e4c96b87896ecffb68f2d1502b9ea.tar.bz2
guru-cc74b8ca6a4e4c96b87896ecffb68f2d1502b9ea.zip
net-im/go-sendxmpp: add 0.5.6
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/go-sendxmpp/Manifest2
-rw-r--r--net-im/go-sendxmpp/go-sendxmpp-0.5.6.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/net-im/go-sendxmpp/Manifest b/net-im/go-sendxmpp/Manifest
index f9e97485e..259b1eb9a 100644
--- a/net-im/go-sendxmpp/Manifest
+++ b/net-im/go-sendxmpp/Manifest
@@ -2,3 +2,5 @@ DIST go-sendxmpp-0.5.4-vendor.tar.xz 1354536 BLAKE2B 198612de41ff68154ad9128134c
DIST go-sendxmpp-0.5.4.tar.bz2 28328 BLAKE2B fabb5ee22f5816c29efb2ab01d064024c4cd3d7dded9498e8f5d856a151723b883cb92ff65994133de220881ca18a1da77b512b2dcd140bcec4f4c47d2523b2e SHA512 270c49a48da12f4f997d83edb6cd71d752a599fef0b1604af57cca12753b890701f028ed1e9e0425ed436d0ee47f6bce00d3e0b5ac8079624dbf5224066b000c
DIST go-sendxmpp-0.5.5-vendor.tar.xz 1352944 BLAKE2B 5bfd87286989b73f59e24576d550daaaa5e305c6066f9bfcc319d4e54c756ffd170bf3313159e1c8bb9a2fc73978057830837ff7fb997095e3bdcea2b323b26b SHA512 bc10809b90e69ebf8efb716b362cd249ac460b40e910242fc4cc06bf08b061e88d6177121b269fa87dd616c66da9dadc72391d1de576b344a09576f5e01867b6
DIST go-sendxmpp-0.5.5.tar.bz2 28743 BLAKE2B a25f569486e130a055f576de12b12ac0d426a22a87da77ae2cfb97a4189cd89359fc00ba0b55a3bcd80c702c3fda705da46817277cebc09f0dd2d6178a044dd9 SHA512 30f8dff625ffa9be83ffcbd0d4a0f5ea28476894a61d7ac7bee3757447a064ed1d73175aaa464d5403bb4f28aead63b87bec2f79815f38f399a17646dff56448
+DIST go-sendxmpp-0.5.6-vendor.tar.xz 1381836 BLAKE2B 1854a7d8fe37da69020c9f9e5df85abd12dde180c27b5242dd2bcf9ae0c7b6dec750dc22dbcdcf39b6ab2a7da89c1c5fe0eb330fa07af731bb7bda4ba40510d2 SHA512 eeaf60e6d0a82ed38d4ee0c3f95822d5d4b1e48f220e19d16f59602a822a27b6041b66abbca20e405aaf95f7e77e17a3e5715a4af444137653c1da7ac5914e54
+DIST go-sendxmpp-0.5.6.tar.bz2 28854 BLAKE2B 30932bc6f6c5665b59f2c3b1586ed7eb6f959b8a08cb861cf136612152c36999bda05727994a5583aa56f0c987f357c9e01d2c6392204c68339e6dd9d92b0c71 SHA512 a5d1241db6fd40a87ec46d5878d9e3f663614d76e6f375cb0f9a208c3960cc3661ac3bd5967cf6f6991c0b408a64facadab36642720a5387644d55fd774c0792
diff --git a/net-im/go-sendxmpp/go-sendxmpp-0.5.6.ebuild b/net-im/go-sendxmpp/go-sendxmpp-0.5.6.ebuild
new file mode 100644
index 000000000..bea4ccb3b
--- /dev/null
+++ b/net-im/go-sendxmpp/go-sendxmpp-0.5.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A little tool to send messages to an XMPP contact or MUC"
+HOMEPAGE="https://salsa.debian.org/mdosch/go-sendxmpp"
+SRC_URI="
+ https://salsa.debian.org/mdosch/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="BSD-2 BSD MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -buildmode=pie
+}
+
+src_install() {
+ dobin go-sendxmpp
+ default
+}