aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2024-09-07 10:34:31 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2024-09-07 10:34:31 +0200
commit9118e90979e184a4ca45e87847bfcaf4dd2fd84b (patch)
treec299f92f50c613b68880c9d26f2ffaa12327449c /net-dialup
parentdev-embedded/arduino-cli: add 1.0.4, drop 1.0.2 (diff)
downloadguru-9118e90979e184a4ca45e87847bfcaf4dd2fd84b.tar.gz
guru-9118e90979e184a4ca45e87847bfcaf4dd2fd84b.tar.bz2
guru-9118e90979e184a4ca45e87847bfcaf4dd2fd84b.zip
net-dialup/tio: add 3.7
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-3.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 750bd9316..1f9e90e18 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-3.6.tar.xz 3458048 BLAKE2B 52152a133b497e7f39f0bb48348ef869ad5fa2135f323796ef16f0caf7c8b3bb5dc38dde7b40c858bd27a1e3addbb97911eef219be5f8b9885638389cd45f9e2 SHA512 daa2f5e8066d22a6bcdda9c0c36b843fdbc8fbcf48eb7e64caa3cb2faabf02634964de5aa5ca5337ed817fe3f51550a677e8773e67b0bf52b0b9012b1e98e13a
+DIST tio-3.7.tar.xz 3458484 BLAKE2B 9cfc4972a58cb6bb5cc70ca26241baba14006834964ee1ac5649c1252cbb214798e6e5d425dc8b9dada9a2d736ebe174841522e012e2eb96f78fc0aec55b8588 SHA512 da4f410ced28efaccaa8fd6a28514831421bd252b91690c8669844b964cdc5039d60b2c7f9dde6468a8475cd12db9f8a49bdfe0c1301f3515d04f75d78a09b76
diff --git a/net-dialup/tio/tio-3.7.ebuild b/net-dialup/tio/tio-3.7.ebuild
new file mode 100644
index 000000000..dead597a8
--- /dev/null
+++ b/net-dialup/tio/tio-3.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/glib
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}