aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-24 09:41:44 +1300
committerTheo Anderson <telans@posteo.de>2020-12-24 09:41:56 +1300
commitc794a4a1011ce5a484720b42ecfe4baef093a13a (patch)
treec9225d297153f50da54b14280e18d9fbe04f81f7 /media-sound
parentmedia-libs/amdvlk: new version 2020.4.6 (diff)
downloadguru-c794a4a1011ce5a484720b42ecfe4baef093a13a.tar.gz
guru-c794a4a1011ce5a484720b42ecfe4baef093a13a.tar.bz2
guru-c794a4a1011ce5a484720b42ecfe4baef093a13a.zip
media-sound/ibniz: fix tc-direct,cflags,pre-strip; depend libsdl[X]
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ibniz/ibniz-1.18.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-sound/ibniz/ibniz-1.18.ebuild b/media-sound/ibniz/ibniz-1.18.ebuild
index 709c52d28..5c80dc61e 100644
--- a/media-sound/ibniz/ibniz-1.18.ebuild
+++ b/media-sound/ibniz/ibniz-1.18.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="virtual machine designed for extremely compact low-level audiovisual programs"
HOMEPAGE="http://pelulamu.net/ibniz/"
SRC_URI="http://pelulamu.net/ibniz/${P}.tar.gz"
@@ -10,11 +12,18 @@ SRC_URI="http://pelulamu.net/ibniz/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="media-libs/libsdl"
+DEPEND="media-libs/libsdl[X]"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ sed -e "s/gcc/$(tc-getCC)/" \
+ -e "s/FLAGS=/FLAGS=${CFLAGS} /" \
+ -e "s/-s //" \
+ -i Makefile
+}
+
src_install() {
dobin ibniz
}