aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtemis Everfree <artemis@artemis.sh>2024-07-24 03:45:28 -0700
committerArtemis Everfree <artemis@artemis.sh>2024-07-24 03:48:00 -0700
commit9c6033ea9ce9c769e9f4a5e23d9919a7a438cf04 (patch)
treed1e3043aefb231a53a0c87b457f8ca1457669671 /media-sound
parentgames-action/ddnet: add 18.4, drop 18.3.1 (diff)
downloadguru-9c6033ea9ce9c769e9f4a5e23d9919a7a438cf04.tar.gz
guru-9c6033ea9ce9c769e9f4a5e23d9919a7a438cf04.tar.bz2
guru-9c6033ea9ce9c769e9f4a5e23d9919a7a438cf04.zip
media-sound/corrscope: fix for numpy 2.x
Signed-off-by: Artemis Everfree <artemis@artemis.sh>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/corrscope/corrscope-0.10.0-r1.ebuild (renamed from media-sound/corrscope/corrscope-0.10.0.ebuild)7
-rw-r--r--media-sound/corrscope/files/remove-npdeprecate.patch12
2 files changed, 18 insertions, 1 deletions
diff --git a/media-sound/corrscope/corrscope-0.10.0.ebuild b/media-sound/corrscope/corrscope-0.10.0-r1.ebuild
index ff81597e0a..ea666260a9 100644
--- a/media-sound/corrscope/corrscope-0.10.0.ebuild
+++ b/media-sound/corrscope/corrscope-0.10.0-r1.ebuild
@@ -4,7 +4,7 @@ EAPI=8
DISTUTILS_USE_PEP517=poetry
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -42,4 +42,9 @@ PATCHES=(
# Ideally, we should upstream a fix that only conditionally imports it,
# but I don't know how to do that right now.
"${FILESDIR}"/remove-appnope-dep.patch
+
+ # corrscope seems to have copied in a modified scipy file to their source
+ # tree. That file uses np.deprecate, which is removed in numpy2. corrscope
+ # doesn't care about this function being marked deprecated, so neither do we
+ "${FILESDIR}"/remove-npdeprecate.patch
)
diff --git a/media-sound/corrscope/files/remove-npdeprecate.patch b/media-sound/corrscope/files/remove-npdeprecate.patch
new file mode 100644
index 0000000000..b165131e30
--- /dev/null
+++ b/media-sound/corrscope/files/remove-npdeprecate.patch
@@ -0,0 +1,12 @@
+diff --git a/corrscope/utils/scipy/windows.py b/corrscope/utils/scipy/windows.py
+index 0eee7f2..8ba1fa4 100644
+--- a/corrscope/utils/scipy/windows.py
++++ b/corrscope/utils/scipy/windows.py
+@@ -816,7 +816,6 @@ def hann(M: int, sym: bool = True) -> np.ndarray:
+ return general_hamming(M, 0.5, sym)
+
+
+-@np.deprecate(new_name='scipy.signal.windows.hann')
+ def hanning(*args, **kwargs):
+ return hann(*args, **kwargs)
+