aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2024-07-16 21:04:52 +0200
committerJonas Frei <freijon@pm.me>2024-07-16 21:05:24 +0200
commit5b9aa829c938f95e8203ff369dd28cee4f432733 (patch)
treefeb7b0ceac0fb459fba53eec5119881c1ee7876c /media-sound
parentgui-apps/clipman: add 1.6.4 (diff)
downloadguru-5b9aa829c938f95e8203ff369dd28cee4f432733.tar.gz
guru-5b9aa829c938f95e8203ff369dd28cee4f432733.tar.bz2
guru-5b9aa829c938f95e8203ff369dd28cee4f432733.zip
media-sound/dzr: add 240704
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dzr/Manifest1
-rw-r--r--media-sound/dzr/dzr-240704.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/dzr/Manifest b/media-sound/dzr/Manifest
index 2f8cf23c5..a20b38b29 100644
--- a/media-sound/dzr/Manifest
+++ b/media-sound/dzr/Manifest
@@ -1 +1,2 @@
DIST dzr-231217.tar.gz 17012 BLAKE2B 4ff6b8c04f7a71612684da82cf49cb5837e44aad44fe7faa7491adb30aaf6c26433f13f2c8b9bee2cbadec125784ea10acfc78d1720bab687f1a1d055874070d SHA512 8c43821295e2062380a399215df478173f4a0984018d712602c654ee88cd902091fb8ec80cd64222e99922c5c4782372f640996c1916e5396cfedefb85f18c24
+DIST dzr-240704.tar.gz 17590 BLAKE2B 655f34f48cb745ac413a9d4d17a10eb7483f6f3d53d6eef69ecc6ec2e682806b620d5ce058dcf72f3e4526976f4b2abb557c1e8253fba017bec5c03d0f6a7723 SHA512 25df76735216b9bf02d68da2faf1fa1db9cfeac7f36e4001e62a26458476739e73f9c5fbb7a10521127bbf9daee434ffd2886f9aeb02617a485d9db9b4e1eb89
diff --git a/media-sound/dzr/dzr-240704.ebuild b/media-sound/dzr/dzr-240704.ebuild
new file mode 100644
index 000000000..94371499e
--- /dev/null
+++ b/media-sound/dzr/dzr-240704.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="DZR: the command line deezer.com player"
+HOMEPAGE="https://github.com/yne/dzr"
+SRC_URI="https://github.com/yne/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-misc/jq[oniguruma]
+ dev-libs/openssl
+ dev-util/dialog
+ media-video/mpv
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ exeinto /usr/bin
+ doexe dzr
+ doexe dzr-dec
+ doexe dzr-id3
+ doexe dzr-srt
+ doexe dzr-url
+ default
+}
+
+pkg_postinst() {
+ einfo "WARNING: For legal reasons this project"
+ einfo "does not contain the track decryption key."
+ einfo "Please read the following guide first:"
+ einfo "https://github.com/yne/dzr/wiki#find-the-dzr_cbc-key"
+}