aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2022-10-31 11:02:57 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2022-10-31 11:03:35 +0100
commit42f1740884f3873fe1fb6513d818067cbd271afc (patch)
tree3749bf0deb6aafd4995ce401d51ee708a24ca4fd /media-sound
parentnet-p2p/bisq-bin: add 1.9.6, drop 1.9.5 (diff)
downloadguru-42f1740884f3873fe1fb6513d818067cbd271afc.tar.gz
guru-42f1740884f3873fe1fb6513d818067cbd271afc.tar.bz2
guru-42f1740884f3873fe1fb6513d818067cbd271afc.zip
media-sound/spotify_dl: add 8.5.0
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify_dl/Manifest1
-rw-r--r--media-sound/spotify_dl/spotify_dl-8.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/spotify_dl/Manifest b/media-sound/spotify_dl/Manifest
index abd4b2e73..b44775459 100644
--- a/media-sound/spotify_dl/Manifest
+++ b/media-sound/spotify_dl/Manifest
@@ -1,2 +1,3 @@
DIST spotify_dl-8.3.0.tar.gz 319579 BLAKE2B d61efe74a84704fef028df4d585b249eafdfbd2d48911f7fa36b72a33edf1a94eedb21b498bd53f4e53ce8a2b4b1b0f7e39caadf320485011717221e7c2eaef5 SHA512 739657d0f2f1bea741de8a2e51bc5be70dbb276d83d0e4555a7767d8c359dfd570c9348eaeccaac30d3097be1214648e798fc6c1de8deab3f346e2e0b89bb04a
DIST spotify_dl-8.4.0.tar.gz 874109 BLAKE2B 832eae3b8c5a943cd35bfa0161fbc67a527e81b70f49274bf11ff1e11a67e19116de44f1e28823060b35f665b702b288cf94a39fa4749b4a7a023edf985a0c77 SHA512 d0a42cc3f28701a72fecb80ce9ffacd14c90edded1f0ea252b6955bf55540568ba559ce78e456b651e1750de52f6cedc8d232a62fdfde708c242d990ba0a76c4
+DIST spotify_dl-8.5.0.tar.gz 874387 BLAKE2B 6c55a428c6c1551f50e11401a675ecb48b6f6f63d84ab262b9f36035268192c257fc93d19b959d13d2583e7704e43c91a49889b8640cda62b5b92e641eee0078 SHA512 afae0ba1a291c91d6bf66d7dad38a4ccda36dfbe1d86b5a239aeebf380e817c58be4041b36eea096efaa5bb2d0abc3460d8f08f4e39923a4644218b1cce20387
diff --git a/media-sound/spotify_dl/spotify_dl-8.5.0.ebuild b/media-sound/spotify_dl/spotify_dl-8.5.0.ebuild
new file mode 100644
index 000000000..2afa04e1f
--- /dev/null
+++ b/media-sound/spotify_dl/spotify_dl-8.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN/_/-}"
+
+DESCRIPTION="Downloads songs from a Spotify Playlist/Track/Album that you provide"
+HOMEPAGE="https://github.com/SathyaBhat/spotify-dl/"
+SRC_URI="https://github.com/SathyaBhat/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="
+ >=dev-python/sentry-sdk-1.5[${PYTHON_USEDEP}]
+ <dev-python/sentry-sdk-2[${PYTHON_USEDEP}]
+ >=net-misc/yt-dlp-2022.1.21[${PYTHON_USEDEP}]
+ >=dev-python/spotipy-2.19[${PYTHON_USEDEP}]
+ <dev-python/spotipy-3[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.45[${PYTHON_USEDEP}]
+ <media-libs/mutagen-2[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0[${PYTHON_USEDEP}]
+ <dev-python/rich-13[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest