aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevrin Talen <devrin@fastmail.com>2024-08-22 16:49:48 -0400
committerDevrin Talen <devrin@fastmail.com>2024-09-04 15:39:53 -0400
commitbeced2858ca08e1dbc5e13ac64cf6b3e5dc7ec08 (patch)
tree1d367c67b3e9a0ed145ad36ecf77f884918460b5 /media-gfx
parentdev-python/system_hotkey: new package, add 1.0.3 (diff)
downloadguru-beced2858ca08e1dbc5e13ac64cf6b3e5dc7ec08.tar.gz
guru-beced2858ca08e1dbc5e13ac64cf6b3e5dc7ec08.tar.bz2
guru-beced2858ca08e1dbc5e13ac64cf6b3e5dc7ec08.zip
media-gfx/superpaper: new package, add 2.2.1
Signed-off-by: Devrin Talen <devrin@fastmail.com>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/superpaper/Manifest1
-rw-r--r--media-gfx/superpaper/metadata.xml12
-rw-r--r--media-gfx/superpaper/superpaper-2.2.1.ebuild107
3 files changed, 120 insertions, 0 deletions
diff --git a/media-gfx/superpaper/Manifest b/media-gfx/superpaper/Manifest
new file mode 100644
index 000000000..2aa53e654
--- /dev/null
+++ b/media-gfx/superpaper/Manifest
@@ -0,0 +1 @@
+DIST superpaper-2.2.1.gh.tar.gz 300503 BLAKE2B b7736551f83ddf8a1976d5388ed52254afc90278e1926a265b064110ddcc55e518096487c6a6bb3f0646f55862ee3262b71136daf44d24854f1e942506b1ddd3 SHA512 869dd8049b05ecd1780b63fd0ddb3d816facef3c8ec68acbefbc1123c846ba1b3344abec633ba070ddf16eafa69ecfc2fb5f05e1cac9983d2b8b37a89bfde04d
diff --git a/media-gfx/superpaper/metadata.xml b/media-gfx/superpaper/metadata.xml
new file mode 100644
index 000000000..6a7298e51
--- /dev/null
+++ b/media-gfx/superpaper/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>devrin@fastmail.com</email>
+ <name>Devrin Talen</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hhannine/superpaper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/superpaper/superpaper-2.2.1.ebuild b/media-gfx/superpaper/superpaper-2.2.1.ebuild
new file mode 100644
index 000000000..cf1d24f4e
--- /dev/null
+++ b/media-gfx/superpaper/superpaper-2.2.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{6..13} )
+inherit distutils-r1
+
+DESCRIPTION="Advanced multi monitor wallpaper manager"
+HOMEPAGE="https://github.com/hhannine/superpaper"
+SRC_URI="https://github.com/hhannine/superpaper/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Run-time dependencies. Must be defined to whatever this depends on to run.
+# Example:
+# ssl? ( >=dev-libs/openssl-1.0.2q:0= )
+# >=dev-lang/perl-5.24.3-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+RDEPEND=">=dev-python/wxpython-4.0
+ >=dev-python/pillow-7.0.0
+ >=dev-python/screeninfo-0.6.1
+ >=dev-python/numpy-1.18.0
+ >=dev-python/system_hotkey-1.0
+ >=dev-python/xcffib-0.8.0
+ >=dev-python/xpybutil-0.0.5"
+
+# Build-time dependencies that need to be binary compatible with the system
+# being built (CHOST). These include libraries that we link against.
+# The below is valid if the same run-time depends are required to compile.
+#DEPEND="${RDEPEND}"
+
+# Build-time dependencies that are executed during the emerge process, and
+# only need to be present in the native build system (CBUILD). Example:
+#BDEPEND="virtual/pkgconfig"
+
+# The following src_configure function is implemented as default by portage, so
+# you only need to call it if you need a different behaviour.
+#src_configure() {
+ # Most open-source packages use GNU autoconf for configuration.
+ # The default, quickest (and preferred) way of running configure is:
+ #econf
+ #
+ # You could use something similar to the following lines to
+ # configure your package before compilation. The "|| die" portion
+ # at the end will stop the build process if the command fails.
+ # You should use this at the end of critical commands in the build
+ # process. (Hint: Most commands are critical, that is, the build
+ # process should abort if they aren't successful.)
+ #./configure \
+ # --host=${CHOST} \
+ # --prefix=/usr \
+ # --infodir=/usr/share/info \
+ # --mandir=/usr/share/man || die
+ # Note the use of --infodir and --mandir, above. This is to make
+ # this package FHS 2.2-compliant. For more information, see
+ # https://wiki.linuxfoundation.org/lsb/fhs
+#}
+
+# The following src_compile function is implemented as default by portage, so
+# you only need to call it, if you need different behaviour.
+#src_compile() {
+ # emake is a script that calls the standard GNU make with parallel
+ # building options for speedier builds (especially on SMP systems).
+ # Try emake first. It might not work for some packages, because
+ # some makefiles have bugs related to parallelism, in these cases,
+ # use emake -j1 to limit make to a single process. The -j1 is a
+ # visual clue to others that the makefiles have bugs that have been
+ # worked around.
+
+ #emake
+#}
+
+# The following src_install function is implemented as default by portage, so
+# you only need to call it, if you need different behaviour.
+#src_install() {
+ # You must *personally verify* that this trick doesn't install
+ # anything outside of DESTDIR; do this by reading and
+ # understanding the install part of the Makefiles.
+ # This is the preferred way to install.
+ #emake DESTDIR="${D}" install
+
+ # When you hit a failure with emake, do not just use make. It is
+ # better to fix the Makefiles to allow proper parallelization.
+ # If you fail with that, use "emake -j1", it's still better than make.
+
+ # For Makefiles that don't make proper use of DESTDIR, setting
+ # prefix is often an alternative. However if you do this, then
+ # you also need to specify mandir and infodir, since they were
+ # passed to ./configure as absolute paths (overriding the prefix
+ # setting).
+ #emake \
+ # prefix="${D}"/usr \
+ # mandir="${D}"/usr/share/man \
+ # infodir="${D}"/usr/share/info \
+ # libdir="${D}"/usr/$(get_libdir) \
+ # install
+ # Again, verify the Makefiles! We don't want anything falling
+ # outside of ${D}.
+#}