aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Nicolas <patricknicolas@laposte.net>2024-10-27 00:14:31 +0200
committerPatrick Nicolas <patricknicolas@laposte.net>2024-10-27 11:39:38 +0100
commit083226de351ba0c684d173bcf42e10cebd07981a (patch)
tree617b1c228fc924053ecb95dc182afaaed16acffc /media-gfx
parentapp-text/typst: drop 0.11.1 (diff)
downloadguru-083226de351ba0c684d173bcf42e10cebd07981a.tar.gz
guru-083226de351ba0c684d173bcf42e10cebd07981a.tar.bz2
guru-083226de351ba0c684d173bcf42e10cebd07981a.zip
media-gfx/KTX-Software: new package, add 4.3.2
Signed-off-by: Patrick Nicolas <patricknicolas@laposte.net>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/KTX-Software/KTX-Software-4.3.2.ebuild44
-rw-r--r--media-gfx/KTX-Software/Manifest1
-rw-r--r--media-gfx/KTX-Software/metadata.xml11
3 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/KTX-Software/KTX-Software-4.3.2.ebuild b/media-gfx/KTX-Software/KTX-Software-4.3.2.ebuild
new file mode 100644
index 000000000..3ead98175
--- /dev/null
+++ b/media-gfx/KTX-Software/KTX-Software-4.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="KTX (Khronos Texture) Library and Tools"
+HOMEPAGE="https://github.com/KhronosGroup/KTX-Software"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+SRC_URI="https://github.com/KhronosGroup/KTX-Software/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+RDEPEND="
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ app-shells/bash
+"
+
+
+src_configure() {
+ # basisu_kernels_sse.cpp has a #error if any of those are set
+ append-cxxflags $(test-flags-CXX -mno-avx)
+ append-cxxflags $(test-flags-CXX -mno-avx2)
+ append-cxxflags $(test-flags-CXX -mno-avx512f)
+ local mycmakeargs=(
+ -DKTX_VERSION=${PV}
+ -DKTX_FEATURE_TESTS=OFF
+ -DBUILD_SHARED_LIBS=OFF # https://github.com/KhronosGroup/KTX-Software/issues/935
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}
diff --git a/media-gfx/KTX-Software/Manifest b/media-gfx/KTX-Software/Manifest
new file mode 100644
index 000000000..ed0a3266c
--- /dev/null
+++ b/media-gfx/KTX-Software/Manifest
@@ -0,0 +1 @@
+DIST KTX-Software-4.3.2.tar.gz 252429885 BLAKE2B 3d0950877c8192f009b8e80c366be152b9b536b84ea899ec43c115a41e7f2d7b896acce36091c3b5507facd16542d4a47f3d49721ecd9e4da146b41a261235f5 SHA512 0077315fe2b4e676e97e3a158c2c6e1f6ba426e14ad23342592cd69be28cfce64c40614e0a84d58a9634877ab334e713b94d4c962132c98bfea308e91bc8a98a
diff --git a/media-gfx/KTX-Software/metadata.xml b/media-gfx/KTX-Software/metadata.xml
new file mode 100644
index 000000000..f860aef64
--- /dev/null
+++ b/media-gfx/KTX-Software/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patricknicolas@laposte.net</email>
+ <name>Patrick Nicolas</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">KhronosGroup/KTX-Software</remote-id>
+ </upstream>
+</pkgmetadata>