aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-25 09:45:24 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-25 09:49:05 -0700
commitaf8ae94474aa36d51d898f0961fc27fbac5cfa28 (patch)
tree9476ff932262124a0f0f1cc97b20caadb7239ec3 /gui-libs
parentapp-portage/portagecfg: Fixed wrong BDEPEND. (diff)
downloadguru-af8ae94474aa36d51d898f0961fc27fbac5cfa28.tar.gz
guru-af8ae94474aa36d51d898f0961fc27fbac5cfa28.tar.bz2
guru-af8ae94474aa36d51d898f0961fc27fbac5cfa28.zip
gui-libs/xdg-desktop-portal-hyprland: Fix patch, live
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch34
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild2
2 files changed, 35 insertions, 1 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
new file mode 100644
index 000000000..2fd5f007c
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
@@ -0,0 +1,34 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 039318f..4f5e882 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -49,6 +49,7 @@ add_compile_options(
+ message(STATUS "Checking deps...")
+ add_subdirectory(hyprland-share-picker)
+
++find_package(sdbus-c++ REQUIRED)
+ find_package(Threads REQUIRED)
+ find_package(PkgConfig REQUIRED)
+ pkg_check_modules(
+@@ -65,12 +66,6 @@ pkg_check_modules(
+ hyprlang>=0.2.0)
+
+ # check whether we can find sdbus-c++ through pkg-config
+-pkg_check_modules(SDBUS IMPORTED_TARGET sdbus-c++)
+-if(NOT SDBUS_FOUND)
+- include_directories("subprojects/sdbus-cpp/include/")
+- add_subdirectory(subprojects/sdbus-cpp EXCLUDE_FROM_ALL)
+- add_library(PkgConfig::SDBUS ALIAS sdbus-c++)
+-endif()
+
+ # same for hyprland-protocols
+ pkg_check_modules(HYPRLAND_PROTOS IMPORTED_TARGET hyprland-protocols)
+@@ -83,7 +78,7 @@ endif()
+ file(GLOB_RECURSE SRCFILES CONFIGURE_DEPENDS "src/*.cpp")
+ add_executable(xdg-desktop-portal-hyprland ${SRCFILES})
+ target_link_libraries(
+- xdg-desktop-portal-hyprland PRIVATE rt PkgConfig::SDBUS Threads::Threads
++ xdg-desktop-portal-hyprland PRIVATE rt sdbus-c++ Threads::Threads
+ PkgConfig::deps)
+
+ # protocols
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
index f49c02593..6bd18e3f8 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
}
src_prepare() {
- eapply "${FILESDIR}/xdg-desktop-portal-hyprland-1.3.2_use_sys_sdbus-c++.patch"
+ eapply "${FILESDIR}/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch"
sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
cmake_src_prepare
}