aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRemigiusz Micielski <rmicielski@purelymail.com>2023-10-07 11:10:16 +0200
committerRemigiusz Micielski <rmicielski@purelymail.com>2023-10-07 11:10:16 +0200
commit5fb80bb1637c3be5125970cab0f84477e6a9c17b (patch)
tree5de90d8bae2904ef6b0aad6a9a555b3dc0ed5140 /gui-libs
parentdev-util/git-bug: drop 0.7.2 (diff)
downloadguru-5fb80bb1637c3be5125970cab0f84477e6a9c17b.tar.gz
guru-5fb80bb1637c3be5125970cab0f84477e6a9c17b.tar.bz2
guru-5fb80bb1637c3be5125970cab0f84477e6a9c17b.zip
gui-libs/xdg-desktop-portal-hyprland: add 1.2.0
Signed-off-by: Remigiusz Micielski <rmicielski@purelymail.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.2.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/Manifest b/gui-libs/xdg-desktop-portal-hyprland/Manifest
index 4f3c894ad..4b77e7152 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/Manifest
+++ b/gui-libs/xdg-desktop-portal-hyprland/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-hyprland-0.5.0.tar.gz 50608 BLAKE2B 7e2c7098f4be1a35c9093b1454c828467dfd52057dc30948ff1824c506115e0a1df8c037d7e85d79c0b845f682285c0fbf6786708537126cc3c94cd05e819a4a SHA512 1efbd3378e9d84f47189264b1b98e65cc73aeea916e31f085ba4503b9e4e25f8121894433adf21d0174ceae3588048a6a83c440cb57e8d2e62301629e93f8c91
DIST xdg-desktop-hyprland-1.1.0.tar.gz 42732 BLAKE2B aa78b9f3a5812988e8324b71cc265c4b2ca23d0b12239c3ac13d068a46200504685da0fb57093f0689101fc2235cb7825646a4669bfe1894928d57a3259df9e3 SHA512 e02fa5bb19ca20cdee9a2e6ad0beb507d96118e095b1e5a1836cc16a35492a9ba5db36b06e5be561adcbf16d8716c38cbb1ed373965416696c69448fbd020c10
+DIST xdg-desktop-hyprland-1.2.0.tar.gz 43068 BLAKE2B 7fcd9cc962d50ade64a97af3bb34a0bfff5c72cb4458ed2dd17122b3ee53364b319d8fbf0db5827bdd94e778a8ddaaba55963fe67fe6d2fe7a7d6265e327c56a SHA512 41201a773756f3b5f49b8a9e39b98fc8939fab60bda24f99d2c3b76a34f159b69fce17af88b6eff2a475e6b097f0d7912b51a8862c2b8cd7cdd9af4e237d17da
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.2.0.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.2.0.ebuild
new file mode 100644
index 000000000..1758dc43b
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-1.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="xdg-desktop-portal backend for hyprland"
+HOMEPAGE="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland/archive/refs/tags/v${PV}.tar.gz \
+ -> xdg-desktop-hyprland-${PV}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.41:=
+ dev-cpp/sdbus-c++
+ dev-libs/inih
+ dev-libs/wayland
+ dev-qt/qtbase
+ dev-qt/qtcore
+ dev-qt/qtgui
+ dev-qt/qtwayland:6
+ dev-qt/qtwidgets
+ media-libs/mesa
+ sys-apps/util-linux
+ x11-libs/libdrm
+ || (
+ systemd? ( >=sys-apps/systemd-237 )
+ elogind? ( >=sys-auth/elogind-237 )
+ sys-libs/basu
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ dev-libs/hyprland-protocols
+ virtual/pkgconfig
+ || ( >=sys-devel/gcc-13:* >=sys-devel/clang-17:* )
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "XDPH needs >=gcc-13 or >=clang-17 to compile."
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile XDPH!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 17 ; then
+ eerror "XDPH needs >=gcc-13 or >=clang-17 to compile."
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile XDPH!"
+ fi
+}
+
+src_compile() {
+ meson_src_compile
+ emake -C hyprland-share-picker all
+}
+
+src_install() {
+ meson_src_install
+ dobin "${S}/hyprland-share-picker/build/hyprland-share-picker"
+}