aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-18 18:08:10 +0000
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-18 18:10:10 +0000
commit0173d5106ad7899cd18b70bd21487b6e375d01e3 (patch)
treead121faa813e0f1e5f85a5de542f2171206f5213 /gui-libs
parentgui-apps/ReGreet:fix cargo depedencys (diff)
downloadguru-0173d5106ad7899cd18b70bd21487b6e375d01e3.tar.gz
guru-0173d5106ad7899cd18b70bd21487b6e375d01e3.tar.bz2
guru-0173d5106ad7899cd18b70bd21487b6e375d01e3.zip
gui-libs/xdg-desktop-portal-hyprland:fix 9999 stbus-c++ patch
* upstream commit: https://github.com/hyprwm/xdg-desktop-portal-hyprland/commit/6a5de92769d5b7038134044053f90e7458f6a197 Closes: https://bugs.gentoo.org/921969 Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch32
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild2
2 files changed, 33 insertions, 1 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
new file mode 100644
index 000000000..c86c5c2c1
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-hyprland/files/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch
@@ -0,0 +1,32 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 73f429b..e760098 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,17 +38,12 @@ add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-value
+ message(STATUS "Checking deps...")
+ add_subdirectory(hyprland-share-picker)
+
++find_package(sdbus-c++ REQUIRED)
+ find_package(Threads REQUIRED)
+ find_package(PkgConfig REQUIRED)
+ pkg_check_modules(deps REQUIRED IMPORTED_TARGET wayland-client wayland-protocols libpipewire-0.3 libspa-0.2 libdrm gbm hyprlang>=0.2.0)
+
+ # check whether we can find sdbus-c++ through pkg-config
+-pkg_check_modules(SDBUS IMPORTED_TARGET sdbus-c++)
+-if(NOT SDBUS_FOUND)
+- include_directories("subprojects/sdbus-cpp/include/")
+- add_subdirectory(subprojects/sdbus-cpp EXCLUDE_FROM_ALL)
+- add_library(PkgConfig::SDBUS ALIAS sdbus-c++)
+-endif()
+
+ # same for hyprland-protocols
+ pkg_check_modules(HYPRLAND_PROTOS IMPORTED_TARGET hyprland-protocols)
+@@ -60,7 +55,7 @@ endif()
+
+ file(GLOB_RECURSE SRCFILES CONFIGURE_DEPENDS "src/*.cpp")
+ add_executable(xdg-desktop-portal-hyprland ${SRCFILES})
+-target_link_libraries(xdg-desktop-portal-hyprland PRIVATE rt PkgConfig::SDBUS Threads::Threads PkgConfig::deps)
++target_link_libraries(xdg-desktop-portal-hyprland PRIVATE rt sdbus-c++ Threads::Threads PkgConfig::deps)
+
+ # protocols
+ find_program(WaylandScanner NAMES wayland-scanner)
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
index 6c155b220..af03bb435 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
@@ -83,7 +83,7 @@ src_unpack() {
}
src_prepare() {
- eapply "${FILESDIR}/xdg-desktop-portal-hyprland-1.3.1_use_sys_sdbus-c++.patch"
+ eapply "${FILESDIR}/xdg-desktop-portal-hyprland-9999_use_sys_sdbus-c++.patch"
sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
cmake_src_prepare
}