aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-01-13 20:46:06 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-01-13 20:59:34 +0900
commit3f774fc02acea94b53ca62c0b4b29e351a3051be (patch)
tree90f4825e97e24ab3cb96ef9981f1479c05081e0e /gui-apps/coreterminal
parentgui-apps/corestuff: add 4.5.0, live sync (diff)
downloadguru-3f774fc02acea94b53ca62c0b4b29e351a3051be.tar.gz
guru-3f774fc02acea94b53ca62c0b4b29e351a3051be.tar.bz2
guru-3f774fc02acea94b53ca62c0b4b29e351a3051be.zip
gui-apps/coreterminal: add 4.5.0, live sync
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'gui-apps/coreterminal')
-rw-r--r--gui-apps/coreterminal/Manifest1
-rw-r--r--gui-apps/coreterminal/coreterminal-4.5.0.ebuild31
-rw-r--r--gui-apps/coreterminal/coreterminal-9999.ebuild19
3 files changed, 39 insertions, 12 deletions
diff --git a/gui-apps/coreterminal/Manifest b/gui-apps/coreterminal/Manifest
index 341dc8692..0739b98f8 100644
--- a/gui-apps/coreterminal/Manifest
+++ b/gui-apps/coreterminal/Manifest
@@ -1 +1,2 @@
DIST coreterminal-4.2.0.tar.gz 74370 BLAKE2B 22d7c677c90bd0cc1910e43f89dcb064064e55c1ea0c816b8c7c5ac2bdfb9c58d6b9cd34941d4088ae28908dbb43e8d34cb02fc41241e5fb144dce9d610b6a7f SHA512 551faaa830b8df57a143c6704aa4f0866b4813e3d037a3582a6d569dbb9fa6d07c28c7008e66a3bb2cee23163fb5fb69c266f18c5f6f6c76dd8356216781898b
+DIST coreterminal-v4.5.0.tar.bz2 73959 BLAKE2B a3ae53915053642eef3b143e67846baeee54aae8db3895be8fd2ab997563b6750e9c2f5b230595e7f21d33a00a07e614cc8eae87be8047bd66e5a8f6b9b89695 SHA512 8084e2525d3ba369b2945c92c7c413ebfe8aca634f2bf64f0402131376e712ae6ff07143ce0afca0dab30274598edb1e10e06d109794d59f5249613083004f06
diff --git a/gui-apps/coreterminal/coreterminal-4.5.0.ebuild b/gui-apps/coreterminal/coreterminal-4.5.0.ebuild
new file mode 100644
index 000000000..9d5bb90c4
--- /dev/null
+++ b/gui-apps/coreterminal/coreterminal-4.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="A terminal emulator for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreterminal"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/coreterminal.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/coreterminal/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+ x11-libs/qtermwidget:=
+"
+RDEPEND="${DEPEND}"
diff --git a/gui-apps/coreterminal/coreterminal-9999.ebuild b/gui-apps/coreterminal/coreterminal-9999.ebuild
index a92b7a682..9d5bb90c4 100644
--- a/gui-apps/coreterminal/coreterminal-9999.ebuild
+++ b/gui-apps/coreterminal/coreterminal-9999.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-MY_PV="${PV/_/-}"
+EAPI=8
inherit xdg cmake
@@ -12,14 +10,13 @@ HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreterminal"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/coreterminal.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/coreterminal/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${MY_PV}"
+ S="${WORKDIR}/${PN}-v${PV}"
fi
-RESTRICT="test"
LICENSE="GPL-3"
SLOT="0"
@@ -29,8 +26,6 @@ DEPEND="
dev-qt/qtserialport:5
dev-qt/qtwidgets:5
gui-libs/libcprime
- x11-libs/qtermwidget
-"
-RDEPEND="
- ${DEPEND}
+ x11-libs/qtermwidget:=
"
+RDEPEND="${DEPEND}"