aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-07 18:04:42 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-07 18:04:42 +0100
commitb2787cc7e2997ee022813432ed8cea694d67ef7a (patch)
tree1cdadc96cf98ca84cc603ef4c428901e5abf2d6c /games-util
parentdev-python/steam: new package, add 1.4.4, 9999 (diff)
downloadguru-b2787cc7e2997ee022813432ed8cea694d67ef7a.tar.gz
guru-b2787cc7e2997ee022813432ed8cea694d67ef7a.tar.bz2
guru-b2787cc7e2997ee022813432ed8cea694d67ef7a.zip
games-util/ProtonUp-Qt: new package, add 2.8.1, 9999
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/ProtonUp-Qt/Manifest1
-rw-r--r--games-util/ProtonUp-Qt/ProtonUp-Qt-2.8.1.ebuild34
-rw-r--r--games-util/ProtonUp-Qt/ProtonUp-Qt-9999.ebuild32
-rw-r--r--games-util/ProtonUp-Qt/files/ProtonUp-Qt2
-rw-r--r--games-util/ProtonUp-Qt/files/ProtonUp-Qt.desktop12
-rw-r--r--games-util/ProtonUp-Qt/metadata.xml7
6 files changed, 88 insertions, 0 deletions
diff --git a/games-util/ProtonUp-Qt/Manifest b/games-util/ProtonUp-Qt/Manifest
new file mode 100644
index 000000000..2d8155143
--- /dev/null
+++ b/games-util/ProtonUp-Qt/Manifest
@@ -0,0 +1 @@
+DIST v2.8.1.tar.gz 753488 BLAKE2B 878bdf08d1098dbd3b2a5ae52bea347f23930fa20d356faf4bc0c74a79acc25fd22ea408bf81b1fe7f57a5266b6cdf56ae8729324dcdb27b291dae676d4c7c76 SHA512 2e1426b61c5c6f1bfc9814795ac4f0c0170235e43252403bb4b2ab4422d6b493c8c6c920ddace4dcbaee6379f747fc9953c8b7222e770541f694ad0f5be6e508
diff --git a/games-util/ProtonUp-Qt/ProtonUp-Qt-2.8.1.ebuild b/games-util/ProtonUp-Qt/ProtonUp-Qt-2.8.1.ebuild
new file mode 100644
index 000000000..86c1a0cf1
--- /dev/null
+++ b/games-util/ProtonUp-Qt/ProtonUp-Qt-2.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+SRC_URI="https://github.com/DavidoTek/ProtonUp-Qt/archive/refs/tags/v${PV}.tar.gz"
+DESCRIPTION="Install and manage GE-Proton, Luxtorpeda & more for Steam and Wine-GE & more for Lutris with this graphical user interface."
+HOMEPAGE="https://davidotek.github.io/protonup-qt"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-python/steam
+ dev-python/requests
+ dev-python/pyside6[designer(+)]
+ dev-python/PyQt6
+ dev-python/vdf
+ dev-python/pyxdg
+ dev-python/pyaml
+ dev-python/zstandard
+"
+
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ insinto /opt/ProtonUp-Qt && doins -r "${WORKDIR}/${P}/pupgui2" && doins -r "${WORKDIR}/${P}/pupgui2"
+
+ insinto /opt/bin/ && doins "${FILESDIR}/ProtonUp-Qt"
+ fperms +x /opt/bin/ProtonUp-Qt
+
+ domenu "${FILESDIR}/ProtonUp-Qt.desktop"
+ newicon "${WORKDIR}/${P}/share/icons/hicolor/64x64/apps/net.davidotek.pupgui2.png" ProtonUp-Qt.png
+} \ No newline at end of file
diff --git a/games-util/ProtonUp-Qt/ProtonUp-Qt-9999.ebuild b/games-util/ProtonUp-Qt/ProtonUp-Qt-9999.ebuild
new file mode 100644
index 000000000..b4d5a4aa9
--- /dev/null
+++ b/games-util/ProtonUp-Qt/ProtonUp-Qt-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 qmake-utils desktop
+EGIT_REPO_URI="https://github.com/DavidoTek/ProtonUp-Qt.git"
+DESCRIPTION="Install and manage GE-Proton, Luxtorpeda & more for Steam and Wine-GE & more for Lutris with this graphical user interface."
+HOMEPAGE="https://davidotek.github.io/protonup-qt"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-python/steam
+ dev-python/requests
+ dev-python/pyside6[designer(+)]
+ dev-python/PyQt6
+ dev-python/vdf
+ dev-python/pyxdg
+ dev-python/pyaml
+ dev-python/zstandard
+"
+
+src_install() {
+ insinto /opt/ProtonUp-Qt && doins -r "${WORKDIR}/${P}/pupgui2" && doins -r "${WORKDIR}/${P}/pupgui2"
+
+ insinto /opt/bin/ && doins "${FILESDIR}/ProtonUp-Qt"
+ fperms +x /opt/bin/ProtonUp-Qt
+
+ domenu "${FILESDIR}/ProtonUp-Qt.desktop"
+ newicon "${WORKDIR}/${P}/share/icons/hicolor/64x64/apps/net.davidotek.pupgui2.png" ProtonUp-Qt.png
+} \ No newline at end of file
diff --git a/games-util/ProtonUp-Qt/files/ProtonUp-Qt b/games-util/ProtonUp-Qt/files/ProtonUp-Qt
new file mode 100644
index 000000000..12a274a03
--- /dev/null
+++ b/games-util/ProtonUp-Qt/files/ProtonUp-Qt
@@ -0,0 +1,2 @@
+#!/bin/sh
+cd /opt/ProtonUp-Qt && python3 -m pupgui2 \ No newline at end of file
diff --git a/games-util/ProtonUp-Qt/files/ProtonUp-Qt.desktop b/games-util/ProtonUp-Qt/files/ProtonUp-Qt.desktop
new file mode 100644
index 000000000..6e23b5725
--- /dev/null
+++ b/games-util/ProtonUp-Qt/files/ProtonUp-Qt.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=ProtonUp-Qt
+Exec=sh -c "cd /opt/ProtonUp-Qt && python3 -m pupgui2"
+Type=Application
+Comment=Install Wine and Proton-based Compatibility Tools
+Comment[de]=Wine und Proton Kompatibilitätstools installieren
+Comment[it]=Installa tool di compatibilità basati su Wine e Proton
+Comment[nl]=Installeer op Wine en Proton gebaseerde compatibiliteitshulpmiddelen
+Comment[pl]=Zainstaluj narzędzia kompatybilności oparte na Wine i Protonie
+Terminal=false
+Icon=ProtonUp-Qt
+Categories=Game;Utility; \ No newline at end of file
diff --git a/games-util/ProtonUp-Qt/metadata.xml b/games-util/ProtonUp-Qt/metadata.xml
new file mode 100644
index 000000000..b981f65b5
--- /dev/null
+++ b/games-util/ProtonUp-Qt/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">DavidoTek/ProtonUp-Qt</remote-id>
+ </upstream>
+</pkgmetadata>