aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-11 23:30:31 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-11 23:54:06 +0100
commit29fd92fd128453518957bebcaea9af9d1466c275 (patch)
tree3cb6d9f3d5b848704067fd91ee2f8015a0024a9a /games-util
parentsci-mathematics/rstudio-desktop-bin: fix SRC_URI (diff)
downloadguru-29fd92fd128453518957bebcaea9af9d1466c275.tar.gz
guru-29fd92fd128453518957bebcaea9af9d1466c275.tar.bz2
guru-29fd92fd128453518957bebcaea9af9d1466c275.zip
games-util/legendary: add 0.20.32
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.20.32.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index 039b1e8e4..53b104765 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,3 +1,4 @@
DIST legendary-0.20.29.tar.gz 129774 BLAKE2B d5876bfb6c8e085221d1c6eee6bf7b0d932bfb648f78eadf32dabb53af203db9081c47094171d648231ef6dd34713f0fac41dea65ce8c23565f32dfaf0efd07f SHA512 70c189b26dfb9e31bd2a8003604b047483bbc1f30eafcf30591dfea52c31dfb016df5173ae88c41b9f91b5370aaa3afc3b9ff7718533fd4003f2369fbc59c67e
DIST legendary-0.20.30.tar.gz 130093 BLAKE2B af1ca08d289de58ff4080a607da0d0a6261c6718061fe57e1852b97936919aef7cf3b7132730cbc1826e535a1dde8c934a6a3be3e5a3c93aa48ebf0108f84aff SHA512 3ae1be8d1aeee7a36ddfdb62b010b7096516518f6a9a264c8a1fedbc87a1e1d6b71e458996536e7e9a350e4d006e73d27cd421a34e94255958ced25e7796b62a
DIST legendary-0.20.31.tar.gz 145145 BLAKE2B 3ad8bd87062a65521c4addd73a1bfd9ded05caf77526dfdf9e0c075d6d557eb5f0db35dbb367ed3d1a1a0b22d22dc9b7d7178b3d887ad5b3e2d8e1e97b7b81e7 SHA512 c4c57b8c6c2161d5df14134457da0c2236f9b88f0e4a2b02ffb910df1d9e74a6907cd3f0d0b4b81b23ed4c9991d8ef0a9d5927ecbe9138cd02998e5020cb7cfe
+DIST legendary-0.20.32.tar.gz 145312 BLAKE2B a59e959ccdc5d7d652b28f9a64474ded7cdf5da5708c61cb76821650802129fe0e5deef47af40c0461ff725b828faa11ca357063f9668acc8a4cceadf34b162f SHA512 9c7b1e944648a0a3a2d228bad2fbf72881299e70409375e1fb4d04ea3ed48226fedc042efcb065463dd1aecb32c8d9656254e3bdd507b1aff5f5cf8ca8e99d56
diff --git a/games-util/legendary/legendary-0.20.32.ebuild b/games-util/legendary/legendary-0.20.32.ebuild
new file mode 100644
index 000000000..806104b33
--- /dev/null
+++ b/games-util/legendary/legendary-0.20.32.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webview"
+
+# NOTE: dev-python/pywebview[qt5] is not much tested and does not function
+# correctly in some cases, according to release notes for 0.20.16.
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ webview? ( dev-python/pywebview[gtk,${PYTHON_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"