aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-07 23:36:29 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-07 23:47:13 +0100
commit88235dbaee3ecfc9b14a54105c088783cbd1f5bb (patch)
treed202fefd392d28a7e5fc0d08cca3be39e21d109b /games-util/protonup
parentdev-python/steam: improve ebuild (diff)
downloadguru-88235dbaee3ecfc9b14a54105c088783cbd1f5bb.tar.gz
guru-88235dbaee3ecfc9b14a54105c088783cbd1f5bb.tar.bz2
guru-88235dbaee3ecfc9b14a54105c088783cbd1f5bb.zip
games-util/protonup: changing name from ProtonUp to protonup
* (fixes version 0.1.5) * improve ebuild Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'games-util/protonup')
-rw-r--r--games-util/protonup/Manifest1
-rw-r--r--games-util/protonup/metadata.xml7
-rw-r--r--games-util/protonup/protonup-0.1.5.ebuild27
-rw-r--r--games-util/protonup/protonup-9999.ebuild25
4 files changed, 60 insertions, 0 deletions
diff --git a/games-util/protonup/Manifest b/games-util/protonup/Manifest
new file mode 100644
index 000000000..55cc01502
--- /dev/null
+++ b/games-util/protonup/Manifest
@@ -0,0 +1 @@
+DIST 0.1.5.tar.gz 17868 BLAKE2B 6ca242e86916e478282bf6a66f4a98911db5e993485b09c631640083ae71f2669fe5b64972b34ab7f97be460877c9493ba99398c1aad9c0e12b02a82f5599d92 SHA512 81b0337ba355ddb5c48adefc736fb6599f04beff59aeabf950844233aea01673d442617f477c7392fde30d818c629b8e807fea820b1119fa22df512523edbd20
diff --git a/games-util/protonup/metadata.xml b/games-util/protonup/metadata.xml
new file mode 100644
index 000000000..535dc7c17
--- /dev/null
+++ b/games-util/protonup/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">AUNaseef/protonup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/protonup/protonup-0.1.5.ebuild b/games-util/protonup/protonup-0.1.5.ebuild
new file mode 100644
index 000000000..a9bb75f5b
--- /dev/null
+++ b/games-util/protonup/protonup-0.1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+EPYTHON=python3
+
+inherit distutils-r1
+SRC_URI="https://github.com/AUNaseef/protonup/archive/refs/tags/${PV}.tar.gz"
+DESCRIPTION="Install and Update Proton-GE"
+HOMEPAGE="https://github.com/AUNaseef/protonup"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
diff --git a/games-util/protonup/protonup-9999.ebuild b/games-util/protonup/protonup-9999.ebuild
new file mode 100644
index 000000000..2508c093c
--- /dev/null
+++ b/games-util/protonup/protonup-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+EPYTHON=python3
+
+inherit git-r3 distutils-r1
+EGIT_REPO_URI="https://github.com/AUNaseef/protonup.git"
+DESCRIPTION="Install and Update Proton-GE"
+HOMEPAGE="https://github.com/AUNaseef/protonup"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}