aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-01-12 00:14:13 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-01-12 00:14:13 +0100
commitcdebd0f323714efbe565193564a69714095e2a80 (patch)
treeeaf2f28979c7867629d44fbc7aaafa5faf3d5531 /games-util/legendary
parentwww-apps/uwebsockets: drop old version (diff)
downloadguru-cdebd0f323714efbe565193564a69714095e2a80.tar.gz
guru-cdebd0f323714efbe565193564a69714095e2a80.tar.bz2
guru-cdebd0f323714efbe565193564a69714095e2a80.zip
games-util/legendary: Version bump 0.20.24
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'games-util/legendary')
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.20.24.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index 5aee2d02a..ab60aafba 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,2 +1,3 @@
DIST legendary-0.20.18.tar.gz 105531 BLAKE2B f321ae20c2d4207df5027ab95a31d7aab3673f38037c2a4a6ea07af999f5471bce1e790836d551f4109a600f6eba9b223db768046c937a05250c9a020b55d2e7 SHA512 25720fc5eee42c180f084a5cc2543c344608a0831bcf4d987d288544ea8164adc48d3c964ffe12fab4967d25a2a3285f3743233c6bf3e94c8934b167756dca15
DIST legendary-0.20.22.tar.gz 111877 BLAKE2B c8e13b18a0c56f115de9518e85aed5ae14bbbf8437485de3f8d935dd343dd984c5f59a0cb45ff574c4c59d762a17226bc9d0c85c9e291a1886560bf8daf123b4 SHA512 23c523a14316b416cfdc035044740a94eab8f05e610638a2d0500f1218b2ce9f0b02163593f2f5b6e97b0fb91d1cf97bc56b275e30502af3b0cc2bc6eee6a175
+DIST legendary-0.20.24.tar.gz 126626 BLAKE2B 4b98f3fd271c252ae9e0bae1b1eba4149f83eb4b4e614fb27f87ac99224bd56534d68927e0dde013917425749c8803ca02ca4ed96d49b844280fe27c93b785a8 SHA512 65727c7917b3675ebd6d2fc91c8f01cd7d32fff21d1bb9b0280c18a4e78e548b92796785647f4576bf44b33af2c8adab0e9b9f631c5e20b7346721c92dab885f
diff --git a/games-util/legendary/legendary-0.20.24.ebuild b/games-util/legendary/legendary-0.20.24.ebuild
new file mode 100644
index 000000000..42ccdcc71
--- /dev/null
+++ b/games-util/legendary/legendary-0.20.24.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webview"
+
+# NOTE: dev-python/pywebview[qt5] is not much tested and does not function
+# correctly in some cases, according to release notes for 0.20.16.
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ webview? ( dev-python/pywebview[gtk,${PYTHON_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"