aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2023-11-27 09:50:10 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2023-11-27 09:53:34 +0100
commit9e9fbb790191cf7d39b41821d77f9f4a3875d651 (patch)
tree0c84c180e87898a6a869ccd3f7b0ce92e39c6244 /games-rpg
parentgui-apps/satty: fix debug useflag and add xdg eclass (diff)
downloadguru-9e9fbb790191cf7d39b41821d77f9f4a3875d651.tar.gz
guru-9e9fbb790191cf7d39b41821d77f9f4a3875d651.tar.bz2
guru-9e9fbb790191cf7d39b41821d77f9f4a3875d651.zip
games-rpg/open-adventure: fix dev-python/pyyaml dependency
Closes: https://bugs.gentoo.org/918627 Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/open-adventure/open-adventure-1.16.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-rpg/open-adventure/open-adventure-1.16.ebuild b/games-rpg/open-adventure/open-adventure-1.16.ebuild
index 2d4d8bd03..0f7514b29 100644
--- a/games-rpg/open-adventure/open-adventure-1.16.ebuild
+++ b/games-rpg/open-adventure/open-adventure-1.16.ebuild
@@ -15,12 +15,15 @@ SLOT="0"
KEYWORDS="~amd64"
BDEPEND="
- ${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]' )
"
DOCS=( NEWS.adoc hints.adoc history.adoc README.adoc notes.adoc )
+python_check_deps() {
+ python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
src_compile() {
emake advent advent.6
}