aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Strizhkin <strdenis02@gmail.com>2024-04-27 10:05:08 +0300
committerDenis Strizhkin <strdenis02@gmail.com>2024-04-27 10:05:21 +0300
commitbd66823ec300b3b1a3629b1a007a3279bbc7bf60 (patch)
tree6efa0164c190fe1de63d2eac268a040b5bd53fc0 /games-puzzle
parentgames-puzzle/katawa-shoujo: put icon into files instead of SRC_URI (diff)
downloadguru-bd66823ec300b3b1a3629b1a007a3279bbc7bf60.tar.gz
guru-bd66823ec300b3b1a3629b1a007a3279bbc7bf60.tar.bz2
guru-bd66823ec300b3b1a3629b1a007a3279bbc7bf60.zip
games-puzzle/katawa-shoujo: add 1.4.7
Signed-off-by: Denis Strizhkin <strdenis02@gmail.com>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/katawa-shoujo/Manifest1
-rw-r--r--games-puzzle/katawa-shoujo/katawa-shoujo-1.4.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/katawa-shoujo/Manifest b/games-puzzle/katawa-shoujo/Manifest
index 59b22db1e..1cd20332d 100644
--- a/games-puzzle/katawa-shoujo/Manifest
+++ b/games-puzzle/katawa-shoujo/Manifest
@@ -1 +1,2 @@
DIST katawa-shoujo-1.4.6.tar.bz2 478087906 BLAKE2B 8c63431b5cb66c5e866b86514e764dafb5ce77d097cefceb091bcd8f75708e0e4fbf4b73229c6a1e3748240d5a5561176a3f623d4539373972376dce212c28b0 SHA512 ebef5a3342384e0e1f9fb4849e923ff606730cfd55ee8182a4c652c7bf2c77f719fc8ff4d43129911490f867927a06d44292a60b15141b1d3d8bd4065e56d36a
+DIST katawa-shoujo-1.4.7.tar.bz2 477918242 BLAKE2B 101b8e9875f85e03b57aa92aaec8c31caee5cbf3ce6b1c1fedeff9f6c51f5a6cc21cbb4d8d4ff12e9d0df9274ae62fe70fe2af2dfdc362d1df47b0cf4be5b843 SHA512 915e6e85e93a352c240d9af2358065d84b790e36da8d58c10da24cd96b0f2334763c10be486e330aa854ea0eb5722796eb4361a6ad590b2cc6ba2e4f4fff6a73
diff --git a/games-puzzle/katawa-shoujo/katawa-shoujo-1.4.7.ebuild b/games-puzzle/katawa-shoujo/katawa-shoujo-1.4.7.ebuild
new file mode 100644
index 000000000..25d8c2981
--- /dev/null
+++ b/games-puzzle/katawa-shoujo/katawa-shoujo-1.4.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper desktop
+
+DESCRIPTION="Re-Engineered visual novel with accessibility features"
+HOMEPAGE="https://www.fhs.sh/projects"
+SRC_URI="
+ https://github.com/fleetingheart/ksre/releases/download/v$PV/KSRE-linux.tar.bz2 -> ${P}.tar.bz2
+"
+S="${WORKDIR}/KSRE-linux"
+
+LICENSE="
+ MPL-2.0
+ CC-BY-NC-ND-3.0
+"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="strip"
+
+src_install() {
+ insinto "/opt/${PN}"
+ doins -r *
+
+ fperms +x "/opt/${PN}/Katawa Shoujo Re-Engineered.sh"
+ fperms +x "/opt/${PN}/lib/py3-linux-x86_64/Katawa Shoujo Re-Engineered"
+
+ make_wrapper "${PN}" "/opt/${PN}/Katawa\ Shoujo\ Re-Engineered.sh"
+
+ domenu "${FILESDIR}/${PN}.desktop"
+ doicon "${FILESDIR}/${PN}.png"
+}