aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-03-17 22:18:18 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-03-17 22:18:18 +0300
commit11a703f98ab98cd7adeae094a0841e33233e45cb (patch)
tree21a5ca49b4229d4a6d2e989a756507f8030d6fb3 /dev-vcs
parentapp-doc/ford: 6.1.10 version bump (diff)
downloadguru-11a703f98ab98cd7adeae094a0841e33233e45cb.tar.gz
guru-11a703f98ab98cd7adeae094a0841e33233e45cb.tar.bz2
guru-11a703f98ab98cd7adeae094a0841e33233e45cb.zip
dev-vcs/lazygit: 0.34 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/lazygit/Manifest1
-rw-r--r--dev-vcs/lazygit/lazygit-0.34.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index 70ac4c31c..c54446e6b 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -1 +1,2 @@
DIST lazygit-0.33.tar.gz 3729628 BLAKE2B 1cd9a081e5c0b5bd1248404771ed0d2617ef07ce1257a14ebaa13eab785d70ead908d3151fa6019fbc5149d24f7d69a351e7137c2c3878e38cd0630751197e9d SHA512 e878ef0eb64a8d3fb536767f33787dbf06fd27deb2a292e9658f1c97073b5c30d95f3390215bf973e90acc136bcddb839024fddcd4bf25e6dab5f2762a2db379
+DIST lazygit-0.34.tar.gz 3733055 BLAKE2B dd53369181f2abf6d7a4776bc751f39a37eb8184fe3811834ee8a99fdcbd4939b260bd1bb86ed26d54b86f4cd509d065cefddcdc5118c266621dfa697a07e7f8 SHA512 a63dd877220c124282667acaadd2f9c55c47687e0c65caff9f61c5a6a3cecc202501fdbd3a1ee13752c8e68bbbb920b5b198459e71a44c585d594675b931d5c2
diff --git a/dev-vcs/lazygit/lazygit-0.34.ebuild b/dev-vcs/lazygit/lazygit-0.34.ebuild
new file mode 100644
index 000000000..ed1a6769b
--- /dev/null
+++ b/dev-vcs/lazygit/lazygit-0.34.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Simple terminal UI for git commands"
+HOMEPAGE="https://github.com/jesseduffield/lazygit"
+SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD ISC MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-vcs/git"
+
+DOCS=( {CODE-OF-CONDUCT,CONTRIBUTING,README}.md docs )
+
+src_prepare() {
+ default
+
+ # remove failing tests
+ rm pkg/gui/*_test.go || die
+}
+
+src_compile() {
+ go build -o bin/lazygit || die
+}
+
+src_test() {
+ ./test.sh || die
+}
+
+src_install() {
+ dobin bin/lazygit
+ einstalldocs
+}