aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-03-25 23:43:38 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2024-03-25 23:48:21 +0300
commit4396db0823bee8e2bbb0dd24387e34d6c9ac6ff9 (patch)
tree548ddd8cbfab3633d9dfc84e8a6b9ec1d702f737 /dev-vcs/gitqlient/gitqlient-9999.ebuild
parentapp-misc/fox-bix: remove my WIP ebuild that was commited by mistake (diff)
downloadguru-4396db0823bee8e2bbb0dd24387e34d6c9ac6ff9.tar.gz
guru-4396db0823bee8e2bbb0dd24387e34d6c9ac6ff9.tar.bz2
guru-4396db0823bee8e2bbb0dd24387e34d6c9ac6ff9.zip
dev-vcs/gitqlient: restore removed package with plugins
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs/gitqlient/gitqlient-9999.ebuild')
-rw-r--r--dev-vcs/gitqlient/gitqlient-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/gitqlient/gitqlient-9999.ebuild b/dev-vcs/gitqlient/gitqlient-9999.ebuild
new file mode 100644
index 000000000..7e5ab5757
--- /dev/null
+++ b/dev-vcs/gitqlient/gitqlient-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 optfeature qmake-utils xdg
+
+MY_PN="GitQlient"
+
+DESCRIPTION="Multi-platform Git client written with Qt"
+HOMEPAGE="https://github.com/francescmm/GitQlient"
+EGIT_REPO_URI="https://github.com/francescmm/${MY_PN}.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
+
+src_configure() {
+ eqmake5 PREFIX=/usr "${MY_PN}".pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ optfeature "Terminal tab plugin support" x11-libs/qtermwidget
+ optfeature "GitServer plugin support" dev-vcs/gitqlient-gitserver-plugin
+ optfeature "Jenkins plugin support" dev-vcs/gitqlient-jenkins-plugin
+ elog "To use plugins set PluginFolder in GitQlient settings Plugin tab to /usr/$(get_libdir)"
+ xdg_pkg_postinst
+}