aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-05-16 03:21:38 +0200
committerMaciej Barć <xgqt@riseup.net>2021-05-16 03:21:57 +0200
commitd556962c2268cc3db8858427754b3999a888617c (patch)
treec13345cb049237f71ff96a61ca933a5eb20f9874 /dev-scheme
parentgui-apps/szyszka: QA_FLAGS_IGNORED (diff)
downloadguru-d556962c2268cc3db8858427754b3999a888617c.tar.gz
guru-d556962c2268cc3db8858427754b3999a888617c.tar.bz2
guru-d556962c2268cc3db8858427754b3999a888617c.zip
dev-scheme/cyclone: add version 0.28.0 and live
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/cyclone/Manifest1
-rw-r--r--dev-scheme/cyclone/cyclone-0.28.0.ebuild51
-rw-r--r--dev-scheme/cyclone/cyclone-9999.ebuild51
-rw-r--r--dev-scheme/cyclone/metadata.xml24
4 files changed, 127 insertions, 0 deletions
diff --git a/dev-scheme/cyclone/Manifest b/dev-scheme/cyclone/Manifest
new file mode 100644
index 000000000..7d9a1e32b
--- /dev/null
+++ b/dev-scheme/cyclone/Manifest
@@ -0,0 +1 @@
+DIST cyclone-0.28.0.tar.gz 3683280 BLAKE2B 7f5e5982104094bbadc9cde545b3d9d21b3f000136ff07543b4fd4f8a5e79799b8adf8c480bc65f15645e62ec9ae5cccc9c5ae9305334ae2ef080eab6d730045 SHA512 e106a0ef779a4829b729a928e30cf80409e6fe6bb14859c595098e0bfe18fcd5d9ba8859d607a55ec2f97b2c58ec8ccb3405b41de34044994441889718c6caec
diff --git a/dev-scheme/cyclone/cyclone-0.28.0.ebuild b/dev-scheme/cyclone/cyclone-0.28.0.ebuild
new file mode 100644
index 000000000..7291e1b0f
--- /dev/null
+++ b/dev-scheme/cyclone/cyclone-0.28.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Cyclone is a self-hosting Scheme to C compiler
+# cyclone-bootstrap is the Cyclone SOURCE transpired by it to C
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Scheme R7RS to C compiler"
+HOMEPAGE="http://justinethier.github.io/cyclone/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/justinethier/${PN}-bootstrap.git"
+else
+ SRC_URI="https://github.com/justinethier/${PN}-bootstrap/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-bootstrap-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/concurrencykit
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ append-cflags -fPIC -rdynamic -Iinclude
+ append-ldflags -L. -Wl,--export-dynamic
+ tc-export CC
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ emake test LDFLAGS=""
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
diff --git a/dev-scheme/cyclone/cyclone-9999.ebuild b/dev-scheme/cyclone/cyclone-9999.ebuild
new file mode 100644
index 000000000..7291e1b0f
--- /dev/null
+++ b/dev-scheme/cyclone/cyclone-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Cyclone is a self-hosting Scheme to C compiler
+# cyclone-bootstrap is the Cyclone SOURCE transpired by it to C
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Scheme R7RS to C compiler"
+HOMEPAGE="http://justinethier.github.io/cyclone/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/justinethier/${PN}-bootstrap.git"
+else
+ SRC_URI="https://github.com/justinethier/${PN}-bootstrap/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-bootstrap-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/concurrencykit
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ append-cflags -fPIC -rdynamic -Iinclude
+ append-ldflags -L. -Wl,--export-dynamic
+ tc-export CC
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ emake test LDFLAGS=""
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
diff --git a/dev-scheme/cyclone/metadata.xml b/dev-scheme/cyclone/metadata.xml
new file mode 100644
index 000000000..befb734c7
--- /dev/null
+++ b/dev-scheme/cyclone/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ Cyclone Scheme is a brand-new compiler that allows real-world
+ application development using the R7RS Scheme Language standard.
+ We provide modern features and a stable system capable of generating
+ fast native binaries.
+ Cheney on the MTA is used by Cyclone's runtime to implement full tail
+ recursion, continuations, and generational garbage collection.
+ In addition, the Cheney on the MTA concept has been extended to allow
+ execution of multiple native threads. An on-the-fly garbage collector
+ is used to manage the second-generation heap and perform major
+ collections without "stopping the world".
+ </longdescription>
+ <upstream>
+ <remote-id type="github">justinethier/cyclone-bootstrap</remote-id>
+ <remote-id type="github">justinethier/cyclone</remote-id>
+ </upstream>
+</pkgmetadata>