aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-12-19 18:28:48 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-12-19 18:47:02 +0500
commit30fa222525f2e5992eedf523aa650e5c1217f200 (patch)
treec2535343fd8e1502d9a4d1f764aca6900e644407 /dev-python
parentnet-misc/maestral: edit deselect comment (diff)
downloadguru-30fa222525f2e5992eedf523aa650e5c1217f200.tar.gz
guru-30fa222525f2e5992eedf523aa650e5c1217f200.tar.bz2
guru-30fa222525f2e5992eedf523aa650e5c1217f200.zip
dev-python/validator-collection: fix deps
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/validator-collection/validator-collection-1.5.0-r2.ebuild (renamed from dev-python/validator-collection/validator-collection-1.5.0-r1.ebuild)24
1 files changed, 11 insertions, 13 deletions
diff --git a/dev-python/validator-collection/validator-collection-1.5.0-r1.ebuild b/dev-python/validator-collection/validator-collection-1.5.0-r2.ebuild
index 911962ae2..8be78c418 100644
--- a/dev-python/validator-collection/validator-collection-1.5.0-r1.ebuild
+++ b/dev-python/validator-collection/validator-collection-1.5.0-r2.ebuild
@@ -8,29 +8,24 @@ PYTHON_COMPAT=( python3_{11..12} )
inherit distutils-r1
-DESCRIPTION="Python library of 60+ commonly-used validator functions."
-HOMEPAGE="https://github.com/insightindustry/validator-collection https://pypi.org/project/validator-collection"
-SRC_URI="https://github.com/insightindustry/validator-collection/archive/refs/tags/v.${PV}.tar.gz -> ${P}.gh.tar.gz"
+DESCRIPTION="Collection of 60+ Python functions for validating data"
+HOMEPAGE="
+ https://github.com/insightindustry/validator-collection
+ https://pypi.org/project/validator-collection
+"
+SRC_URI="https://github.com/insightindustry/${PN}/archive/refs/tags/v.${PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}/${PN}-v.${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/sphinx-tabs[${PYTHON_USEDEP}]
- dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/pytest-benchmark[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/codecov[${PYTHON_USEDEP}]
dev-python/pyfakefs[${PYTHON_USEDEP}]
)
"
-DEPEND="${BDEPEND}"
EPYTEST_DESELECT=(
# Errors, probably because of missing privileges or problems in the virtual file system used in the tests
@@ -41,4 +36,7 @@ EPYTEST_DESELECT=(
)
distutils_enable_tests pytest
-distutils_enable_sphinx docs
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-tabs