aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2025-01-21 13:48:22 +0100
committerHenri Gasc <gasc@eurecom.fr>2025-01-22 01:48:26 +0100
commit2b382d2dc9df1ac13aec32b3ccf12f89965e3a6d (patch)
treeb061d21501419fff4d3ccd632591575e07c84471 /dev-python
parentapp-i18n/fcitx-skk: treeclean (diff)
downloadguru-2b382d2dc9df1ac13aec32b3ccf12f89965e3a6d.tar.gz
guru-2b382d2dc9df1ac13aec32b3ccf12f89965e3a6d.tar.bz2
guru-2b382d2dc9df1ac13aec32b3ccf12f89965e3a6d.zip
dev-python/icecream: add 2.1.4, drop 2.1.3
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/icecream/Manifest2
-rw-r--r--dev-python/icecream/icecream-2.1.4.ebuild (renamed from dev-python/icecream/icecream-2.1.3.ebuild)15
2 files changed, 7 insertions, 10 deletions
diff --git a/dev-python/icecream/Manifest b/dev-python/icecream/Manifest
index 875e4c6ea..08debb956 100644
--- a/dev-python/icecream/Manifest
+++ b/dev-python/icecream/Manifest
@@ -1 +1 @@
-DIST icecream-2.1.3.gh.tar.gz 38879 BLAKE2B 0a3f1e1c75730255dee4d11ffd5954bc0b6d84eb971865300f00e2015fba84561d179cc1640766841cb58483b741e14bb36ace31a6e4cee67321cb385fd85995 SHA512 b319109248c7ae65a24fe7fa85b7900435a3f681466612c0c25769fe3ee4cd2bc5305bff8be1bd36ca26064d54cf9738b58d24a6c1d9b3d3ebe93228656b3ee3
+DIST icecream-2.1.4.gh.tar.gz 23930 BLAKE2B ac58c117b706cdbb5736203304228c0837ca987631714b5b083e5826ff065b889c1149a7c0b60878fce850654f1eb1ddaa6f4a98f7b24fdd31605c5a66c0ea80 SHA512 3ac6e567ca11d41e32966abc7a822180ac62e4840f28f06cde051e2717a8b81990a137b24f3a62fa5da35394a7fe0a2d6efbac70a1a0e610143fcb05ddd19007
diff --git a/dev-python/icecream/icecream-2.1.3.ebuild b/dev-python/icecream/icecream-2.1.4.ebuild
index ccaf099cd..068de642b 100644
--- a/dev-python/icecream/icecream-2.1.3.ebuild
+++ b/dev-python/icecream/icecream-2.1.4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Pythonic task execution"
@@ -18,18 +19,14 @@ KEYWORDS="~amd64"
RDEPEND="
>=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
>=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/executing-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
>=dev-python/asttokens-2.0.1[${PYTHON_USEDEP}]
"
distutils_enable_tests unittest
python_prepare_all() {
- # https://github.com/gruns/icecream/pull/147
- sed -i 's/assertRegexpMatches/assertRegex/' tests/test_icecream.py || die
+ # Install tests package otherwise
+ sed -i 's/find_packages()/find_packages(exclude=["tests", "tests.*"])/' "${S}"/setup.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- eunittest tests
-}