aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Elbert <kcelbert@gmail.com>2025-01-20 23:57:39 -0600
committerKyle Elbert <kcelbert@gmail.com>2025-01-20 23:57:39 -0600
commit02d66da0e6341617ddfbbac4e61b614d7f653e92 (patch)
tree3a839634fec7ee9ec4e0ecc741e5ae2433f8444a /dev-python
parentdev-python/pyrr: treeclean (diff)
downloadguru-02d66da0e6341617ddfbbac4e61b614d7f653e92.tar.gz
guru-02d66da0e6341617ddfbbac4e61b614d7f653e92.tar.bz2
guru-02d66da0e6341617ddfbbac4e61b614d7f653e92.zip
dev-python/cloudflare: drop 3.1.0-r3
Signed-off-by: Kyle Elbert <kcelbert@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cloudflare/Manifest2
-rw-r--r--dev-python/cloudflare/cloudflare-3.1.0-r3.ebuild101
2 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/cloudflare/Manifest b/dev-python/cloudflare/Manifest
index 6d6b44285..2a7fa2788 100644
--- a/dev-python/cloudflare/Manifest
+++ b/dev-python/cloudflare/Manifest
@@ -1,3 +1 @@
DIST cloudflare-2.19.4.gh.tar.gz 151397 BLAKE2B c91c95f52314c5177d823ef8f827ea2f76f6cc703260449aea12d54c1b77d061feca15d4bb845f84cfb4fd80789e5064e54d7530daf546d54d17054b9e0b4fda SHA512 8ae11e73760c57b610abfe5e2c8fdc83c2e0b9e07340884925ec9ac3bf5b40b4edf39b2b8ce7330538369d7573146a2ddac195efb0efb4ff657f75fdacb31aed
-DIST cloudflare-3.1.0.gh.tar.gz 1436993 BLAKE2B 136ed341bd16bd04165d94c10d82b2ad617a434728b290aff1dfc9bf11193786011224feeef567455df451efc7921c41c9835e80413738f80db60b3213396df8 SHA512 72f42012e8b4a4497523d159139ebbcef99b75f58a55a429ecb3dcdcfdad3ce3b3694cccb06bc6ec72c6148b1e1516083bda0fb43babdeb8933561e5821fbb1d
-DIST cloudflare-python-3.1.0-prism.tar.gz 10537403 BLAKE2B 67caa6b98f452890ea9613e875d534ddb14c8d3720af5c57bceb04e2e3518702ecafe1bf37f02e53818f8cbc5c6bd8c799c18342879b07d39ba64831168f5495 SHA512 718f968755c62aa4b66bbf3659437751734c3183d6c5d48b025b72355d59414578bb0748f01fa38d46c33736af10d52742723a4eda47d9868d86ec2b499ece27
diff --git a/dev-python/cloudflare/cloudflare-3.1.0-r3.ebuild b/dev-python/cloudflare/cloudflare-3.1.0-r3.ebuild
deleted file mode 100644
index 1a309e4b3..000000000
--- a/dev-python/cloudflare/cloudflare-3.1.0-r3.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{11..12} )
-DISTUTILS_USE_PEP517="hatchling"
-inherit distutils-r1
-DESCRIPTION="Python wrapper for the Cloudflare v4 API"
-HOMEPAGE="https://pypi.org/project/cloudflare/"
-if [ "${PV}" == 9999 ]; then
- EGIT_REPO_URI="https://github.com/cloudflare/cloudflare-python"
- inherit git-r3
-else
- MYPV=$(ver_rs 3 -)
- MYPV=${MYPV/beta/beta.}
- MYPN="cloudflare-python"
- SRC_URI="https://github.com/cloudflare/cloudflare-python/archive/refs/tags/v${MYPV}.tar.gz -> ${P}.gh.tar.gz
- test? ( https://github.com/Phoenix591/${MYPN}/releases/download/${PV}/${MYPN}-${PV}-prism.tar.gz )"
- #Prism archive generated by workflow
- # https://github.com/Phoenix591/cloudflare-python/blob/master/.github/workflows/test-tar.yml
- S="${WORKDIR}/${MYPN}-${MYPV}"
- KEYWORDS="~amd64 ~arm64"
-fi
-LICENSE="MIT test? ( ISC Apache-2.0 MIT BSD CC0-1.0 0BSD )"
-# nodejs module and deps used to test
-SLOT="3"
-RDEPEND=" ${DEPEND}
- >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
- =dev-python/pydantic-2.9*[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/anyio-4.3.0[${PYTHON_USEDEP}]
- >=dev-python/distro-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.3.1[${PYTHON_USEDEP}]
- <dev-python/httpx-0.28.0[${PYTHON_USEDEP}]
- "
-
-BDEPEND="test? (
- >=net-libs/nodejs-18.20.1
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/time-machine[${PYTHON_USEDEP}]
- dev-python/dirty-equals[${PYTHON_USEDEP}]
- dev-python/respx[${PYTHON_USEDEP}]
- ${RDEPEND}
-)"
-
-distutils_enable_tests pytest
-RESTRICT+=" !test? ( test )"
-
-src_unpack() {
- unpack "${P}.gh.tar.gz"
- use test && cd "${S}" && unpack "cloudflare-python-${PV}-prism.tar.gz"
-}
-
-#python_prepare_all() {
-# # don't install tests or examples
-# sed -i -e "s/'cli4', 'examples'/'cli4'/" \
-# -e "s#'CloudFlare/tests',##" \
-# setup.py || die
-# sed -i -e "/def test_ips7_should_fail():/i@pytest.mark.xfail(reason='Now fails upstream')" \
-# -e "2s/^/import pytest/" \
-# CloudFlare/tests/test_cloudflare_calls.py || die
-# distutils-r1_python_prepare_all
-#}
-
-python_test() {
- # these 2 tests fail in an ebuild environment for some reason
- # help appreciated
- local EPYTEST_DESELECT=(
- tests/test_client.py::TestCloudflare::test_validate_headers
- tests/test_client.py::TestAsyncCloudflare::test_validate_headers )
- #intermittently fail for unknown reasons, passed along to upstream
- EPYTEST_DESELECT+=(
- tests/test_client.py::TestAsyncCloudflare::test_copy_build_request
- tests/test_client.py::TestCloudflare::test_copy_build_request )
- epytest
-}
-
-src_test() {
- start_mock
- distutils-r1_src_test
- stop_mock
-}
-start_mock() {
-# Run prism mock api server, this is what needs nodejs
- node --no-warnings node_modules/@stoplight/prism-cli/dist/index.js mock \
- "cloudflare-spec.yml" >prism.log || die "Failed starting prism" &
- echo $! >"${T}/mock.pid" || die
- # Wait for server to come online
- echo -n "Waiting for mockserver"
- while ! grep -q "✖ fatal\|Prism is listening" "prism.log" ; do
- echo -n "." || die
- sleep 0.5
- done
- if grep -q "✖ fatal" prism.log; then
- die "Prism mock server failed"
- fi
-}
-stop_mock() {
- kill $(cat "${T}/mock.pid") || die
-}