aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro-Barbieri <lssndrbarbieri@gmail.com>2021-06-20 05:14:53 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-21 01:17:24 +0200
commit5c8b17906edb527c5e5226279d0a4f1bbc15da74 (patch)
tree9240296f7dc57621d024a20e2d18cca1ef9913b4 /dev-python/os-win/os-win-5.1.0.ebuild
parentdev-R/*: add unbundling status (diff)
downloadguru-5c8b17906edb527c5e5226279d0a4f1bbc15da74.tar.gz
guru-5c8b17906edb527c5e5226279d0a4f1bbc15da74.tar.bz2
guru-5c8b17906edb527c5e5226279d0a4f1bbc15da74.zip
*/*: restore openstack
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/os-win/os-win-5.1.0.ebuild')
-rw-r--r--dev-python/os-win/os-win-5.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/os-win/os-win-5.1.0.ebuild b/dev-python/os-win/os-win-5.1.0.ebuild
new file mode 100644
index 000000000..f6392bbcb
--- /dev/null
+++ b/dev-python/os-win/os-win-5.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+"